IBM Support

Attempting to open an iBase database results in a 'SQL Server does not exist' error

Troubleshooting


Problem

After migrating an iBase database to a new SQL server, the following error message is displayed when attempting to open the database in the iBase client: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. An error occurred in: idDBSystem:Logon idDBSystem:OpenSF FMain:DoCommand(LogOn)

Cause

This error can occur if the iBase database has been migrated to a new server which has a different hostname. The existing IDS file will be configured to connect to the old (no longer existing) hostname, so the connection attempt will fail.

Resolving The Problem

Use the iBase Database Configuration Tool to reconfigure the IDS security file so that it points to the new SQL Server:

Please note that for the tool to work, the IDS file must be able to create a connection to it's existing (old) server entry. You may need to bring your old SQL Server online, so that the IDS file can connect to it while you make the changes.

1. Open the iBase Database Configuration Tool (Start > All Programs > IBM i2 iBase 8 > Tools)
2. Using the tool, browse to your iBase security (IDS) file, enter login credentials and click Next
3. Use the configuration screen to update the hostname for your SQL server, and enter appropriate login credentials. Click on Save to apply your changes and exit the tool.

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Document Information

More support for:
i2 iBase

Software version:
8.1, 8.5, 8.9, 8.9.1, 8.9.5

Operating system(s):
Windows

Document number:
261761

Modified date:
16 June 2018

UID

swg21882850