IBM Support

Archive failed to access sysmaster database

Troubleshooting


Problem

When performing an archive, it is possible to receive an error that the archive process cannot access the sysmaster database.

Resolving The Problem


PROBLEM

During an ontape or onbar archive process, you receive the following error message:

    Archive failed – access sysmaster database (SQL:-206 ISAM:-111)


CAUSE

The database server was unsuccessful in building the sysmaster database during initialization.


SOLUTION

As user informix, run the buildsmi script rebuild the sysmaster database.

    On a UNIX platform:
      $INFORMIXDIR/etc/buildsmi.sh
    On a Windows platform:
      %INFORMIXDIR%\etc\buildsmi.bat
[{"Product":{"code":"SSGU8G","label":"Informix Servers"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF025","label":"Platform Independent"},{"code":"PF008","label":"DYNIX\/ptx"},{"code":"PF010","label":"HP-UX"},{"code":"PF015","label":"IRIX"},{"code":"PF016","label":"Linux"},{"code":"PF026","label":"Reliant UNIX"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.2;7.3;9.2;9.3;9.4;10.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSGU5D","label":"Informix Extended Parallel Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.x","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

More support for:
Informix Servers

Software version:
7.2, 7.3, 9.2, 9.3, 9.4, 10.0

Operating system(s):
AIX, DYNIX/ptx, HP-UX, IRIX, Linux, Reliant UNIX, Solaris, Windows

Document number:
338993

Modified date:
16 June 2018

UID

swg21202544

Manage My Notification Subscriptions