IBM Support

PK97186: UNABLE TO CONFIGURE INFORMIX WITH DB2/JCC DRIVER ON CEI

Fixes are available

7.0.0.9: WebSphere Application Server V7.0 Fix Pack 9 for IBM i
7.0.0.9: WebSphere Application Server V7.0 Fix Pack 9 for Windows
7.0.0.9: WebSphere Application Server V7.0 Fix Pack 9 for AIX
7.0.0.9: WebSphere Application Server V7.0 Fix Pack 9 for HP-UX
7.0.0.9: Java SDK 1.6 SR7 Cumulative Fix for WebSphere Application Server
7.0.0.9: WebSphere Application Server V7.0 Fix Pack 9 for Solaris
7.0.0.9: WebSphere Application Server V7.0 Fix Pack 9 for Linux
PK97186; 7.0.0.7: Unable to configure Informix with DB2/JCC driver on CEI
7.0.0.11: WebSphere Application Server V7.0 Fix Pack 11 for IBM i
7.0.0.11: WebSphere Application Server V7.0 Fix Pack 11 for Windows
7.0.0.11: WebSphere Application Server V7.0 Fix Pack 11 for HP-UX
7.0.0.11: WebSphere Application Server V7.0 Fix Pack 11 for AIX
7.0.0.11: Java SDK 1.6 SR7 Cumulative Fix for WebSphere Application Server
7.0.0.11: WebSphere Application Server V7.0 Fix Pack 11 for Solaris
7.0.0.11: WebSphere Application Server V7.0 Fix Pack 11 for Linux
7.0.0.13: WebSphere Application Server V7.0 Fix Pack 13 for AIX
7.0.0.13: WebSphere Application Server V7.0 Fix Pack 13 for HP-UX
7.0.0.13: WebSphere Application Server V7.0 Fix Pack 13 for IBM i
7.0.0.13: WebSphere Application Server V7.0 Fix Pack 13 for Linux
7.0.0.13: WebSphere Application Server V7.0 Fix Pack 13 for Solaris
7.0.0.13: WebSphere Application Server V7.0 Fix Pack 13 for Windows
7.0.0.13: Java SDK 1.6 SR8FP1 Cumulative Fix for WebSphere Application Server
7.0.0.15: WebSphere Application Server V7.0 Fix Pack 15 for AIX
7.0.0.15: Java SDK 1.6 SR9 Cumulative Fix for WebSphere Application Server
7.0.0.15: WebSphere Application Server V7.0 Fix Pack 15 for HP-UX
7.0.0.15: WebSphere Application Server V7.0 Fix Pack 15 for IBM i
7.0.0.15: WebSphere Application Server V7.0 Fix Pack 15 for Linux
7.0.0.15: WebSphere Application Server V7.0 Fix Pack 15 for Solaris
7.0.0.15: WebSphere Application Server V7.0 Fix Pack 15 for Windows
7.0.0.17: WebSphere Application Server V7.0 Fix Pack 17
7.0.0.17: Java SDK 1.6 SR9 FP1 Cumulative Fix for WebSphere Application Server
7.0.0.19: WebSphere Application Server V7.0 Fix Pack 19
7.0.0.21: WebSphere Application Server V7.0 Fix Pack 21
7.0.0.23: WebSphere Application Server V7.0 Fix Pack 23
7.0.0.25: WebSphere Application Server V7.0 Fix Pack 25
7.0.0.27: WebSphere Application Server V7.0 Fix Pack 27
7.0.0.29: WebSphere Application Server V7.0 Fix Pack 29
7.0.0.31: WebSphere Application Server V7.0 Fix Pack 31
7.0.0.27: Java SDK 1.6 SR13 FP2 Cumulative Fix for WebSphere Application Server
7.0.0.33: WebSphere Application Server V7.0 Fix Pack 33
7.0.0.35: WebSphere Application Server V7.0 Fix Pack 35
7.0.0.19: Java SDK 1.6 SR9 FP2 Cumulative Fix for WebSphere Application Server
7.0.0.21: Java SDK 1.6 SR9 FP2 Cumulative Fix for WebSphere
7.0.0.23: Java SDK 1.6 SR10 FP1 Cumulative Fix for WebSphere
7.0.0.25: Java SDK 1.6 SR11 Cumulative Fix for WebSphere Application Server
7.0.0.27: Java SDK 1.6 SR12 Cumulative Fix for WebSphere Application Server
7.0.0.29: Java SDK 1.6 SR13 FP2 Cumulative Fix for WebSphere Application Server
7.0.0.45: Java SDK 1.6 SR16 FP60 Cumulative Fix for WebSphere Application Server
7.0.0.31: Java SDK 1.6 SR15 Cumulative Fix for WebSphere Application Server
7.0.0.35: Java SDK 1.6 SR16 FP1 Cumulative Fix for WebSphere Application Server
7.0.0.37: Java SDK 1.6 SR16 FP3 Cumulative Fix for WebSphere Application Server
7.0.0.39: Java SDK 1.6 SR16 FP7 Cumulative Fix for WebSphere Application Server
7.0.0.41: Java SDK 1.6 SR16 FP20 Cumulative Fix for WebSphere Application Server
7.0.0.43: Java SDK 1.6 SR16 FP41 Cumulative Fix for WebSphere Application Server

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • Common Event Infrastructure (CEI) datasources are still being
    configured with
    com.ibm.websphere.rsadapter.InformixDataStoreHelper
    instead of
    com.ibm.websphere.rsadapter.InformixJccDataStoreHelper"
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  IBM WebSphere Application Server users who  *
    *                  configure Common Event Infrastructure with  *
    *                  an Informix database.                       *
    ****************************************************************
    * PROBLEM DESCRIPTION: The configuration of the Common Event   *
    *                      Infrastructure with Informix database   *
    *                      does not support IBM Data Server        *
    *                      Driver for JDBC.                        *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    The automatic configuration process of Common Event
    Infrastructure with an Informix database creates the
    WebSphere Application Server data source based on the Informix
    JDBC Driver (XA) driver version (considered as the default).
    Common Event Infrastructure configuration supports the data
    source to be configured with a provider based on Informix
    Using IBM DB2 JDBC Universal Driver or Informix Using IBM JCC
    Driver as well. If the users need to base their data source on
    one of the above options, they will be able to do so by using
    a manual procedure via the Administrative Console. The
    automatic configuration process for Common event
    Infrastructure should support these cases as well.
    

Problem conclusion

  • The automatic configuration process with Informix database has
    been changed by adding to the configEventServiceInformixDB
    configuration Admin Task a new optional parameter
    -jdbcDriverVersion that will accept the following
    possible/acceptable values jta / 3.0 / 4.0. By using the ?jta?
    value it will configure the JDBC provider to use Informix JDBC
    Driver for JTA/XA. The usage of ?3.0? value will determine the
    configuration of the JDBC provider to be based on the Informix
    Using IBM DB2 JDBC Universal Driver (XA) version whereas using
    the 4.0 value will produce the JDBC provider based on the
    Informix Using IBM JCC Driver (XA) version.
    The introduced behavior is:
    a. -jdbcDriverVersion not specified in the AdminTask - The
    configuration will be performed using ?Informix JDBC Driver
    (XA)', therefore Informix JDBC Driver for JTA/XA driver version.
    b. -jdbcDriverVersion specified but no value supplied - Will
    raise an exception as -jdbcDriverVersion needs a parameter,
    then if the user go so far as to use the parameter but does
    NOT supply a value, we give an error stating like in the
    following example "CEIIN0739E No value was specified for the
    jdbcDriverVersion parameter.?
    c. -jdbcDriverVersion specified with the 'jta' value supplied
    - The configuration will be performed using 'Informix JDBC
    Driver for JTA/XA'.
    d. -jdbcDriverVersion specified with the '3.0' value supplied
    - The configuration will be performed using 'Informix Using
    IBM DB2 JDBC Universal Driver'.
    e. -jdbcDriverVersion specified with the '4.0' value supplied
    - The configuration will be performed using 'Informix Using
    IBM JCC Driver (XA)', therefore based on the provider that
    supports JDBC 4.0 specification using the IBM Data Server
    Driver for JDBC and SQLJ version.
    f. -jdbcDriverVersion specified with a value OTHER than jta,
    3.0 or 4.0 - Will raise an exception like in the following
    example: "CEIIN0701E The parameter jdbcDriverVersion contains
    the value <wrong_value>, which is not valid. Valid values are:
    jta, 3.0, 4.0."
    
    
    The fix for this APAR is currently targeted for inclusion in
    fix pack 7.0.0.9.  Please refer to the Recommended Updates
    page for delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

Comments

APAR Information

  • APAR number

    PK97186

  • Reported component name

    WEBSPHERE APP S

  • Reported component ID

    5724J0800

  • Reported release

    700

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2009-09-25

  • Closed date

    2009-10-16

  • Last modified date

    2009-10-16

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBSPHERE APP S

  • Fixed component ID

    5724J0800

Applicable component levels

  • R700 PSY

       UP

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.0","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
25 October 2021