IBM Support

PI99188: CANNOT CREATE SNAPSHOT FROM CLI USING COMPONENT ID

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • In previous versions of UCD, snapshots could be created from the
    CLI by referencing components by their ID. However, in 6.2.7.2,
    the CLI command explicitly checks for name only. When attempting
    to create snapshots this way, the user will receive an error
    saying "Component not found with name:<component id>".
    
    This is a regression from prior versions of UrbanCode Deploy.
    

Local fix

  • You can still create snapshots from the CLI using component
    names.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All end users on all supported browsers.                     *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * In previous versions of UCD, snapshots could be created from *
    * the                                                          *
    * CLI by referencing components by their ID. However, in       *
    * 6.2.7.2,                                                     *
    * the CLI command explicitly checks for name only. When        *
    * attempting                                                   *
    * to create snapshots this way, the user will receive an error *
    * saying "Component not found with name:<component id>".       *
    *                                                              *
    * This is a regression from prior versions of UrbanCode        *
    * Deploy.                                                      *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Fixed in version 7.1.1.1                                     *
    ****************************************************************
    

Problem conclusion

  • Fix is provided in IBM UrbanCode Deploy 7.1.1.1
    

Temporary fix

Comments

APAR Information

  • APAR number

    PI99188

  • Reported component name

    UC DEPLOY

  • Reported component ID

    5725M5400

  • Reported release

    627

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2018-06-14

  • Closed date

    2020-11-16

  • Last modified date

    2020-11-16

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    UC DEPLOY

  • Fixed component ID

    5725M5400

Applicable component levels

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU029","label":"Software"},"Product":{"code":"SS4GSP","label":"IBM UrbanCode Deploy"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"627"}]

Document Information

Modified date:
17 November 2020