IBM Support

PI80230: Cannot update custom action under the health policy when configuration validation is set higher than Low

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • From adminconsole go toTroubleshooting ->
    Configuration problems to open validation policy page and
    set
    the policy to " High: Validate extracted, parent, and local
    sibling documents" (by default "Low") and click Apply. Then
    go
    to Operational policies > Custom action > try to edit
    existing
    custom action, it will prompt you to save the changes
    without
    being made any changes. Also, if you try to create new
    custom
    action, after final step you would see below error in the
    adminconsole.
    
    Updates from another session have been saved to the master
    configuration since you started this session. The changes
    you
    made conflict with these updates and cannot be saved. To
    continue, you must discard your changes to reset your
    workspace
    and work from the current, saved version of the master
    configuration.
    
    Also, see below error in ffdc log file
    
    Exception:com.ibm.websphere.management.exception.DocumentAlr
    eady
    ExistsException
    SourceId:com.ibm.ws.management.repository.FileRepository.pre
    Crea
    teProbeId:536
    Reporter:com.ibm.ws.management.repository.FileRepository@aac
    8063
    a
    com.ibm.websphere.management.exception.DocumentAlreadyExists
    Exce
    ption:
    cells/Cell_PROD/customprocessdefs/Mail Notify - Connection
    pool
    full//customprocessdefs.xml
    at
    com.ibm.ws.management.repository.FileRepository.preCreate(Fi
    leRe
    pository.java:759)
    at
    com.ibm.ws.management.repository.FileRepository.preUpdate(Fi
    leRe
    pository.java:1472)
    at
    com.ibm.ws.management.repository.FileRepository.update(FileR
    epos
    itory.java:1410)
    at
    com.ibm.ws.management.repository.client.LocalConfigRepositor
    yCli
    ent.update(LocalConfigRepositoryClient.java:189)
    at
    com.ibm.ws.sm.workspace.impl.WorkSpaceMasterRepositoryAdapte
    r.up
    date(WorkSpaceMasterRepositoryAdapter.java:667)
    

Local fix

  • Set websphere configuration problems validation policy to "Low"
    (From console go to Troubleshooting ->
    Configuration problems to open validation policy page)
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server WAS ND edition- Virtual              *
    *                  Enterprise/IM Component with the custom     *
    *                  action feature of health policy and setting *
    *                  the level of configuration validation Low.  *
    ****************************************************************
    * PROBLEM DESCRIPTION: Cannot update custom action under the   *
    *                      health policy since it always shows     *
    *                      conflict with the existing action on    *
    *                      editing.                                *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    When the configuration validation (Config validation is on
    Troubleshooting->Configuration problems on WAS administrative
    console) set to a level above Low, which is default, a user will
    not be able to update the existing custom action under the
    health policy (or add new one) since it will always show
    configuration conflict and force the user to discard the
    change.
    

Problem conclusion

  • The level of configuration validation should not affect the
    activity of custom action.  Made a change to fix the problem.
    
    The fix for this APAR is currently targeted for inclusion in fix
    pack 8.5.5.12.  Please refer to the Recommended Updates page for
    delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

  • Do not set the configuration validation level higher than Low.
    

Comments

APAR Information

  • APAR number

    PI80230

  • Reported component name

    WEBS APP SERV N

  • Reported component ID

    5724H8800

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2017-04-19

  • Closed date

    2017-05-11

  • Last modified date

    2017-05-11

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBS APP SERV N

  • Fixed component ID

    5724H8800

Applicable component levels

  • R850 PSY

       UP

[{"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSCVS22","label":"General"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"850","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
11 May 2017