IBM Support

PI71667: Application fails with WELD-001408: Unsatisfied dependencies for type Validator with qualifiers @Default

Fixes are available

9.0.0.2: WebSphere Application Server traditional V9.0 Fix Pack 2
16.0.0.4: WebSphere Application Server Liberty 16.0.0.4
9.0.0.3: WebSphere Application Server traditional V9.0 Fix Pack 3
9.0.0.4: WebSphere Application Server traditional V9.0 Fix Pack 4
9.0.0.5: WebSphere Application Server traditional V9.0 Fix Pack 5
9.0.0.6: WebSphere Application Server traditional V9.0 Fix Pack 6
9.0.0.7: WebSphere Application Server traditional V9.0 Fix Pack 7
17.0.0.1: WebSphere Application Server Liberty 17.0.0.1
17.0.0.2: WebSphere Application Server Liberty 17.0.0.2
17.0.0.3: WebSphere Application Server Liberty 17.0.0.3
17.0.0.4: WebSphere Application Server Liberty 17.0.0.4
18.0.0.1: WebSphere Application Server Liberty 18.0.0.1
18.0.0.2: WebSphere Application Server Liberty 18.0.0.2
9.0.0.8: WebSphere Application Server traditional V9.0 Fix Pack 8
9.0.0.9: WebSphere Application Server traditional V9.0 Fix Pack 9
18.0.0.3: WebSphere Application Server Liberty 18.0.0.3
9.0.0.10: WebSphere Application Server traditional V9.0 Fix Pack 10
18.0.0.4: WebSphere Application Server Liberty 18.0.0.4
19.0.0.1: WebSphere Application Server Liberty 19.0.0.1
19.0.0.2: WebSphere Application Server Liberty 19.0.0.2
19.0.0.3: WebSphere Application Server Liberty 19.0.0.3
9.0.0.11: WebSphere Application Server traditional V9.0 Fix Pack 11
19.0.0.4: WebSphere Application Server Liberty 19.0.0.4
19.0.0.5: WebSphere Application Server Liberty 19.0.0.5
9.0.5.0: WebSphere Application Server traditional Version 9.0.5 Refresh Pack
19.0.0.6: WebSphere Application Server Liberty 19.0.0.6
19.0.0.7: WebSphere Application Server Liberty 19.0.0.7
19.0.0.8: WebSphere Application Server Liberty 19.0.0.8
9.0.5.1: WebSphere Application Server traditional Version 9.0.5 Fix Pack 1
19.0.0.9: WebSphere Application Server Liberty 19.0.0.9
19.0.0.10: WebSphere Application Server Liberty 19.0.0.10
19.0.0.11: WebSphere Application Server Liberty 19.0.0.11
9.0.5.2: WebSphere Application Server traditional Version 9.0.5 Fix Pack 2
19.0.0.12: WebSphere Application Server Liberty 19.0.0.12
20.0.0.1: WebSphere Application Server Liberty 20.0.0.1
20.0.0.2: WebSphere Application Server Liberty 20.0.0.2
9.0.5.3: WebSphere Application Server traditional Version 9.0.5 Fix Pack 3
20.0.0.3: WebSphere Application Server Liberty 20.0.0.3
20.0.0.4: WebSphere Application Server Liberty 20.0.0.4
20.0.0.5: WebSphere Application Server Liberty 20.0.0.5

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • If your application includes the class Validator.class
    (including in internal jar files) Liberty may get confused
    between the the classfile in your application and the class
    file installed inside liberty itself leading to a
    WELD-001408: Unsatisfied dependencies for type Validator
    with qualifiers @Default exception.
     -
    Other errors seen are:
    CWWKZ0002E: An exception occurred while starting the application
    app-name.
    The exception message was:
    com.ibm.ws.container.service.state.StateChangeException:
    org.jboss.weld.exceptions.DeploymentException:
    WELD-001408: Unsatisfied dependencies for type Validator with
    qualifiers @Default
     at injection point ÝUnbackedAnnotatedField¨
      @Inject private org.apache.bval.cdi.BValInterceptor.validator
     at org.apache.bval.cdi.BValInterceptor.validator
       (BValInterceptor.java:0)
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server Liberty - Contexts and Dependency    *
    *                  Injection (CDI)                             *
    ****************************************************************
    * PROBLEM DESCRIPTION: Application fails with WELD-001408:     *
    *                      Unsatisfied dependencies for type       *
    *                      Validator with qualifiers @Default      *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    If your application includes the class Validator.class
    (including in internal jar files) Liberty may get confused
    between the the classfile in your application and the class file
    installed inside liberty itself leading to a WELD-001408:
    Unsatisfied dependencies for type Validator with qualifiers
    @Default exception.
    

Problem conclusion

  • The relevant part of the code now searches through Liberty's
    class files before the application's class files.
    
    The fix for this APAR is currently targeted for inclusion in fix
    pack 16.0.0.4.  Please refer to the Recommended Updates page for
    delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

  • Disable implicit beans scanning
    
    Liberty: add  <cdi12 enableImplicitBeanArchives="false"/>  to
    your server.xml
    Websphere: see http://www-
    01.ibm.com/support/docview.wss?uid=swg21983564
    
    If your application uses cdi then you will also need to add a
    beans.xml file or files to reenable bean scanning. So long as
    you do not have a beans.xml this in the same war or jar file as
    Validator.class it will resolve this issue.
    

Comments

APAR Information

  • APAR number

    PI71667

  • Reported component name

    WAS LIBERTY COR

  • Reported component ID

    5725L2900

  • Reported release

    CD0

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2016-11-02

  • Closed date

    2016-11-08

  • Last modified date

    2016-11-14

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WAS LIBERTY COR

  • Fixed component ID

    5725L2900

Applicable component levels

  • RCD0 PSY

       UP

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSD28V","label":"WebSphere Application Server Liberty Core"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"CD0","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
17 June 2020