IBM Support

PI51236: WASPOSTUPGRADE NOT SETTING VIRTUALHOSTS PORTS CORRECTLY.

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • When running WASPostUpgrade with options
    "-replacePorts false"  & "-portBlock nnnn" all the ports were
    replaced with the new port numbers but the virtualHosts ports
    were not replaced. The ports in the serverindex.xml were
    defined correctly but the ports in the virtualHosts.xml were
    not.
    

Local fix

  • Need to manually change the ports in the virtualHosts on V8.5
    system.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server Migration Utilities                  *
    ****************************************************************
    * PROBLEM DESCRIPTION: Virtual Host ports are incorrect        *
    *                      after migration.                        *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    The ports in the virtual host xml file are not being updated
    properly when -replacePorts false and -portBlock <nnnnn> is
    used.
    

Problem conclusion

  • There are four scenarios for handling ports during migration:
    1) -replacePorts false with no -portBlock
    2) -replacePorts false with a -portBlock setting
    3) -replacePorts true with no -portBlock
    4) -replacePorts true with a -portBlock setting
    
    This error happens for case number 4).  In this case migration
    provides a complete set of new ports.  The old ports are
    discarded as well as the new ports supplied by profile creation.
    Migration was not taking this scenario into account when
    processing the virtualHost.xml file. This has been corrected.
    
    The fix for this APAR is currently targeted for inclusion in
    fix pack 8.5.5.9.  Please refer to the Recommended Updates
    page for delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

Comments

APAR Information

  • APAR number

    PI51236

  • Reported component name

    WEBSPHERE APP S

  • Reported component ID

    5724J0800

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2015-10-26

  • Closed date

    2015-11-30

  • Last modified date

    2015-11-30

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBSPHERE APP S

  • Fixed component ID

    5724J0800

Applicable component levels

  • R850 PSY

       UP

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.5","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
28 April 2022