A fix is available
APAR status
Closed as program error.
Error description
During an OSGi JVMSERVER shutdown, the following error occurs in osgi.log: org.osgi.framework.BundleException: Exception in org.apache.aries.jndi.startup.Activator.stop() of bundle com.ibm.ws.org.apache.aries.jndi.core. ... Caused by: java.lang.IllegalStateException: java.lang.reflect.InaccessibleObjectException: Unable to make field private static javax.naming.spi.ObjectFactoryBuilder com.sun.naming.internal.NamingManagerHelper. object_factory_builder accessible: module java.naming does not "opens com.sun.naming.internal" to unnamed module @cd923d7f ... Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make field private static javax.naming.spi. ObjectFactoryBuilder com.sun.naming.internal. NamingManagerHelper.object_factory_builder accessible: module java.naming does not "opens com.sun.naming.internal" to unnamed module @cd923d7f ... Root exception: java.lang.IllegalStateException: java.lang.reflect.InaccessibleObjectException: Unable to make field private static javax.naming.spi.ObjectFactoryBuilder com.sun.naming.internal.NamingManagerHelper. object_factory_builder accessible: module java.naming does not "opens com.sun.naming.internal" to unnamed module @cd923d7f There is no adverse impact on JVMSERVER functionality aside from this error being displayed in the osgi.log during shutdown.
Local fix
Problem summary
**************************************************************** * USERS AFFECTED: All CICS users. * **************************************************************** * PROBLEM DESCRIPTION: org.osgi.framework.BundleException * * occurs in osgi.log when an OSGi * * JVMSERVER using Java 21 or higher is * * shutdown. * **************************************************************** When an OSGi JVMSERVER using Java 21 or higher is shutdown, an org.osgi.framework.BundleException is written to the osgi.log. This is caused by the Apache Aries JNDI bundle (com.ibm.ws.org.apache.aries.jndi.core) attempting to access resources using reflection and does not result in any negative effects on JVMSERVER functionality.
Problem conclusion
CICS has been updated to ensure OSGi JVMSERVERs are started with the following JVM option to correct this error: --add-opens java.naming/com.sun.naming.internal
Temporary fix
Comments
APAR Information
APAR number
PH72403
Reported component name
CICS TS Z/OS V6
Reported component ID
5655YA100
Reported release
500
Status
CLOSED PER
PE
NoPE
HIPER
NoHIPER
Special Attention
NoSpecatt / Xsystem
Submitted date
2026-07-24
Closed date
2026-09-03
Last modified date
2026-09-04
APAR is sysrouted FROM one or more of the following:
APAR is sysrouted TO one or more of the following:
UO09247 UO09248
Modules/Macros
DFHSJSC DFJ@H467 DFJ@H609 DFJ@H642
Fix information
Fixed component name
CICS TS Z/OS V6
Fixed component ID
5655YA100
Applicable component levels
Fix is available
Select the PTF appropriate for your component level. You will be required to sign in. Distribution on physical media is not available in all countries.
[{"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.2","Line of Business":{"code":"LOB70","label":"Z TPS"}}]
Document Information
Modified date:
04 September 2026