IBM Support

PH36858: ADD WARNING DURING SERVER START WHEN TLSV1 OR TLSV1.1 IS CONFIGURED.

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • Would like to warn users that they are using protocols that
    are consideres weak.  The SSL configurations will be check
    during server startup to check for TLSv1 and TLSv1.1 protocols
    if there are configuration with the weak protocols a warning
    is issued to the logs.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server                                      *
    ****************************************************************
    * PROBLEM DESCRIPTION: Need to issue warning when TLSv1 or     *
    *                      TLSv1.1 are enabled.                    *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    The TLSv1 and TLSv1.1 protocols are considered weak.  If
    WebSphere is configures with the protocols a warning is issued
    recommending the user configure to use TLSv1.2 or higher.
    

Problem conclusion

  • Issuing warning if customers are configure with TLSv1,
    TLSv1.1, or SSL_TLS.  Also issuing a warning when configured
    with SSL_TLSv2 as it can allow for TLSv1 and TLSv1.1.
    
    The fix for this APAR is targeted for inclusion in fix pack
    8.5.5.20 and 9.0.5.9. For more information, see 'Recommended
    Updates for WebSphere Application Server':
    https://www.ibm.com/support/pages/node/715553
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH36858

  • Reported component name

    WEBSPHERE APP S

  • Reported component ID

    5724J0800

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2021-04-30

  • Closed date

    2021-06-07

  • Last modified date

    2021-06-07

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBSPHERE APP S

  • Fixed component ID

    5724J0800

Applicable component levels

[{"Line of Business":{"code":"LOB36","label":"IBM Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"850"}]

Document Information

Modified date:
08 June 2021