IBM Support

PH35470: PMI STATS FOR THE SERVLET ARE NOT COLLECTED FOR APPLICATION UNTIL APPLICATION IS RESTARTED

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • In the case where the servlet is defined with:
    <load-on-startup>1</load-on-startup>
    
    And these SMF settings enabled:
    server_SMF_request_activity_CPU_detail=1
    server_SMF_request_activity_enabled=1
    
    The servlet PMI stats are zero until the application is
    restarted
    

Local fix

  • restart application or disable
    server_SMF_request_activity_enabled
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  IBM WebSphere Application Server for z/OS   *
    *                  version 8.5.5 and 9.0 users of servlets     *
    *                  with PMI and SMF enabled.                   *
    ****************************************************************
    * PROBLEM DESCRIPTION: Missing PMI stats for servlets using    *
    *                      load-on-startup while SMF enabled.      *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    There is a condition during server startup where applications
    that have specified servlet load-on-startup and the server
    property server_SMF_request_activity_CPU_detail=1 defined will
    have missing Performance Monitoring Infrastructure (PMI) data
    for that servlet until the application is recycled.  The issue
    is that load-on-startup causes the servlet to initialize PMI,
    but then the first System Management Facility (SMF) collection
    request at a point later in time also does PMI
    initialization resulting in the original PMI object to be lost.
    

Problem conclusion

  • This WebContainer fix resolves the PMI collection issue when
    both servlet load-on-startup in an application and SMF
    collection in the server are set.
    
    The fix for this APAR is currently targeted for inclusion in
    fixpack 8.5.5.20 and 9.0.5.8.
    
    Please refer to the recommended updates page for delivery
    information:
    
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH35470

  • Reported component name

    WEBSPHERE FOR Z

  • Reported component ID

    5655I3500

  • Reported release

    900

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2021-03-17

  • Closed date

    2021-03-31

  • Last modified date

    2021-03-31

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBSPHERE FOR Z

  • Fixed component ID

    5655I3500

Applicable component levels

[{"Line of Business":{"code":"LOB36","label":"IBM Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS7K4U","label":"WebSphere Application Server for z\/OS"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"900"}]

Document Information

Modified date:
01 April 2021