IBM Support

PH33029: IDZ 15.0 CODE COVERAGE RESULTS VIEW PRESENTS WRONG RESULT ON ADDING NEW RESULT, OR RESTARTING THE IDE.

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • IDz 15.0 Eclipse IDE's Code Coverage Results view presents
    incorrect result when new result is added to a result location,
    or when restarting IDE. This occurs mostly when result is added
    via importing a result or running code coverage to generate
    result to default location Compiled Code Coverage Workspace
    Results. It can also happened on refreshing the view, restarting
    the IDE and deleting a result too.
    
    Steps to reproduce:
    Generated some Code Coverage Results in Compiled Code Coverage
    Workspace Results at first, then it shows wrong coverage result
    after restarting IDE or adding new result or refreshing the
    view.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * Users who use code coverage or view code coverage results.   *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * The percentage of the imported code coverage result shown in *
    * the view is incorrect.                                       *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    

Problem conclusion

  • Code coverage result will be analyzed correctly, to display
    correct result on code coverage view and code coverage result
    report viewer when it is opened.
    
    The problem is fixed in 15.0.1 for the following products:
    IBM Debug for z/OS
    IBM Developer for z/OS
    IBM Developer for z/OS Enterprise Edition
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH33029

  • Reported component name

    DEV FOR Z/OS

  • Reported component ID

    5724T0700

  • Reported release

    F00

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2021-01-03

  • Closed date

    2021-03-18

  • Last modified date

    2021-03-18

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    DEV FOR Z/OS

  • Fixed component ID

    5724T0700

Applicable component levels

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU029","label":"Software"},"Product":{"code":"SSQ2R2","label":"Rational Developer for System z"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"F00"}]

Document Information

Modified date:
19 March 2021