IBM Support

PH30566: AFTER UPDATING TO WAS 8.5.5.18 AND WAS V9.0.5.5 ACCESSING THE ADMIN CONSOLE FAILS WITH 500 ERROR

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

APAR status

  • Closed as program error.

Error description

  • The client is using RAD. The problem is seen on the Internal
    Web Browser and external browsers also. The problem is only
    seen when accessing the browser the first time.
    
    The
    systemout.log shows these errors:
    [10/13/20 17:36:37:835 PDT]
    000000ca ServletWrappe E
    com.ibm.ws.webcontainer.servlet.ServletWrapper service
    SRVE0014E: Uncaught service() exception root cause action:
    javax.servlet.ServletException:
    java.lang.NullPointerException
    at org.apache.struts.action.Reque
    stProcessor.processException(Unknown Source)
    ...
    Caused by:
    java.lang.NullPointerException
    at com.ibm.isclite.runtime.action
    .LoginAction.getBeginNavAppNavString
    (LoginAction.java:980)
    at c
    om.ibm.isclite.runtime.action.LoginAction.handleBeginNavAppNavIn
    Request
    (LoginAction.java:1027)
    at com.ibm.isclite.runtime.actio
    n.LoginAction.execute(LoginAction.java:314)
    

Local fix

  • 
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM Rational Application       *
    *                  Developer with WebSphere Application        *
    *                  Server 8.5.5.18, 9.0.5.4, 9.0.5.5.          *
    ****************************************************************
    * PROBLEM DESCRIPTION: The first login attempt to the          *
    *                      admin console fails with error 500.     *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    The first login attempt to admin console fails with error
    500. Subsequent login attempts are successfuly when refreshing
    the browser.
    

Problem conclusion

  • The codes causing the first login attempt to fail has been fixed
    
    The fix for this APAR is targeted for inclusion in fix packs
    8.5.5.19 and 9.0.5.6. For more information, see 'Recommended
    Updates
    for
    WebSphere Application Server':
    https://www.ibm.com/support/pages/node/715553
    

Temporary fix

  • 
    

Comments

  • 
    

APAR Information

  • APAR number

    PH30566

  • Reported component name

    WEBSPHERE APP S

  • Reported component ID

    5724J0800

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2020-10-14

  • Closed date

    2020-11-22

  • Last modified date

    2020-12-07

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBSPHERE APP S

  • Fixed component ID

    5724J0800

Applicable component levels

[{"Line of Business":{"code":"LOB36","label":"IBM Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"850"}]

Document Information

Modified date:
16 March 2021