IBM Support

PH29687: ENTERING HTTPS URL IN AGENT RELAY URL (IN AGENT CONFIGURATION TEMPLATE) - ERROR IS NOT CLEAR TO USE HTTP

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • In an agent configuration template , using a HTTPS URL like
    https://<IPaddress>:<IP port>
    in the agent relay url field results in an unclear error.
    It says "invalid URL" instead of specifying that the URL needs
    to be HTTP.
    
    Expecting error as : HTTPS URL is not valid , need to use HTTP
    proxy URL  instead of "Invalid URL"
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All end users on all supported browsers.                     *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * In an agent configuration template , using a HTTPS URL like  *
    * https://<IPaddress>:<IP port>                                *
    * in the agent relay url field results in an unclear error.    *
    * It says "invalid URL" instead of specifying that the URL     *
    * needs                                                        *
    * to be HTTP.                                                  *
    *                                                              *
    * Expecting error as : HTTPS URL is not valid , need to use    *
    * HTTP                                                         *
    * proxy URL  instead of "Invalid URL"                          *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Fixed in version 7.1.2.1                                     *
    ****************************************************************
    

Problem conclusion

  • Fix is provided in IBM UrbanCode Deploy 7.1.2.1
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH29687

  • Reported component name

    UC DEPLOY

  • Reported component ID

    5725M5400

  • Reported release

    710

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2020-09-21

  • Closed date

    2021-04-12

  • Last modified date

    2021-04-12

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    UC DEPLOY

  • Fixed component ID

    5725M5400

Applicable component levels

[{"Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS4GSP","label":"IBM UrbanCode Deploy"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"710"}]

Document Information

Modified date:
13 April 2021