IBM Support

PH28456: UPGRADING TO 7.1.0.1.IFIX01 THROWS "UNTERMINATED ' CHARACTER?" ERROR DUE TO INCORRECT AMOUNT OF SINGLE QUOTES

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • Upgrade of UCD from 6.2.10 to 7.1.0.1.ifix01.1062130 fails with
    the below error
    
    ERROR
    
        [upgrade] Found n1_6.2.3 current version: 0
          [upgrade] Applying n1_6.2.3 change: 1 - Create temporary
    table for deleted environment cleanup
    
         [upgrade] Applying n1_6.2.3 change: 2 - Inserting deleted
    rows in vc for objects which are associated with deleted
    environments: com.urbancode.cm.db.updater.ApplyException:
    java.lang.IllegalStateException: Failed to process query.
    Unterminated ' character?
        	at
    com.urbancode.cm.db.updater.DbUpgradeTask.executeMultiVersionUpg
    rade(DbUpgradeTask.java:273)
        	at
    com.urbancode.cm.db.updater.DbUpgradeTask.execute(DbUpgradeTask.
    java:81)
        ...
        Caused by: java.lang.IllegalStateException: Failed to
    process query. Unterminated ' character?
        ...
        	at
    
    upgrade_002_db2_add_deleted_version_in_vc_for_objects_associated
    _with_deleted_environments$_run_closure3.doCall(upgrade_002_db2_
    add_deleted_version_in_vc_for_objects_associated_with_deleted_en
    vironments.groovy:72)
        	at
    
    upgrade_002_db2_add_deleted_version_in_vc_for_objects_associated
    _with_deleted_environments$_run_closure3.doCall(upgrade_002_db2_
    add_deleted_version_in_vc_for_objects_associated_with_deleted_en
    vironments.groovy)
        ...
        	at
    
    upgrade_002_db2_add_deleted_version_in_vc_for_objects_associated
    _with_deleted_environments.run(upgrade_002_db2_add_deleted_versi
    on_in_vc_for_objects_associated_with_deleted_environments.groovy
    :147)
        	at
    com.urbancode.cm.db.updater.GroovyDbUpdaterAction.apply(GroovyDb
    UpdaterAction.java:74)
        	... 119 more
             [echo] Install Failed. (press return to exit installer)
    
    Database involved is DB2.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All end users on all supported browsers.                     *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * Upgrade of UCD from 6.2.10 to 7.1.0.1.ifix01.1062130 fails   *
    * with                                                         *
    * the below error                                              *
    *                                                              *
    * ERROR                                                        *
    *                                                              *
    *     [upgrade] Found n1_6.2.3 current version: 0              *
    *       [upgrade] Applying n1_6.2.3 change: 1 - Create         *
    * temporary                                                    *
    * table for deleted environment cleanup                        *
    *                                                              *
    *      [upgrade] Applying n1_6.2.3 change: 2 - Inserting       *
    * deleted                                                      *
    * rows in vc for objects which are associated with deleted     *
    * environments: com.urbancode.cm.db.updater.ApplyException:    *
    * java.lang.IllegalStateException: Failed to process query.    *
    * Unterminated ' character?                                    *
    *     	at                                                      *
    * com.urbancode.cm.db.updater.DbUpgradeTask.executeMultiVersio *
    * nUpg                                                         *
    * rade(DbUpgradeTask.java:273)                                 *
    *     	at                                                      *
    * com.urbancode.cm.db.updater.DbUpgradeTask.execute(DbUpgradeT *
    * ask.                                                         *
    * java:81)                                                     *
    *     ...                                                      *
    *     Caused by: java.lang.IllegalStateException: Failed to    *
    * process query. Unterminated ' character?                     *
    *     ...                                                      *
    *     	at                                                      *
    *                                                              *
    * upgrade_002_db2_add_deleted_version_in_vc_for_objects_associ *
    * ated                                                         *
    * _with_deleted_environments$_run_closure3.doCall(upgrade_002_ *
    * db2_                                                         *
    * add_deleted_version_in_vc_for_objects_associated_with_delete *
    * d_en                                                         *
    * vironments.groovy:72)                                        *
    *     	at                                                      *
    *                                                              *
    * upgrade_002_db2_add_deleted_version_in_vc_for_objects_associ *
    * ated                                                         *
    * _with_deleted_environments$_run_closure3.doCall(upgrade_002_ *
    * db2_                                                         *
    * add_deleted_version_in_vc_for_objects_associated_with_delete *
    * d_en                                                         *
    * vironments.groovy)                                           *
    *     ...                                                      *
    *     	at                                                      *
    *                                                              *
    * upgrade_002_db2_add_deleted_version_in_vc_for_objects_associ *
    * ated                                                         *
    * _with_deleted_environments.run(upgrade_002_db2_add_deleted_v *
    * ersi                                                         *
    * on_in_vc_for_objects_associated_with_deleted_environments.gr *
    * oovy                                                         *
    * :147)                                                        *
    *     	at                                                      *
    * com.urbancode.cm.db.updater.GroovyDbUpdaterAction.apply(Groo *
    * vyDb                                                         *
    * UpdaterAction.java:74)                                       *
    *     	... 119 more                                            *
    *          [echo] Install Failed. (press return to exit        *
    * installer)                                                   *
    *                                                              *
    * Database involved is DB2.                                    *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Fixed in version 7.1.2.0                                     *
    ****************************************************************
    

Problem conclusion

  • Fix is provided in IBM UrbanCode Deploy 7.1.2.0
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH28456

  • Reported component name

    UC DEPLOY

  • Reported component ID

    5725M5400

  • Reported release

    710

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2020-08-13

  • Closed date

    2021-02-16

  • Last modified date

    2021-02-16

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    UC DEPLOY

  • Fixed component ID

    5725M5400

Applicable component levels

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU029","label":"Software"},"Product":{"code":"SS4GSP","label":"IBM UrbanCode Deploy"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"710"}]

Document Information

Modified date:
26 February 2021