IBM Support

PH21828: COMPONENT PROCESS PROPERTY'S SECURE VALUES ARE OUTPUT AS ***** IN PLACE OF TEXT WHEN RUN VIA APP => COMPONENT => RUN PROCESS

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • Run a component process from the application, "Application =>
    Component => Run Process",
    the default value of the Component's secure Component Process
    Property is echoed to a file as "****" and not in clear text.
    Edit the secure property at run time, the undisguised value
    appears in the file as expected.
    
    Run the component process via an Application process,
    "Application => Request Process",
    the default value appears in the file as clear text as expected.
    

Local fix

  • Edit the value when running the process request.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All end users on all supported browsers.                     *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * Run a component process from the application, "Application   *
    * =>                                                           *
    * Component => Run Process",                                   *
    * the default value of the Component's secure Component        *
    * Process                                                      *
    * Property is echoed to a file as "****" and not in clear      *
    * text.                                                        *
    * Edit the secure property at run time, the undisguised value  *
    * appears in the file as expected.                             *
    *                                                              *
    * Run the component process via an Application process,        *
    * "Application => Request Process",                            *
    * the default value appears in the file as clear text as       *
    * expected.                                                    *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Fixed in version 7.1.0.0                                     *
    ****************************************************************
    

Problem conclusion

  • Fix is provided in IBM UrbanCode Deploy 7.1.0.0
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH21828

  • Reported component name

    UC DEPLOY

  • Reported component ID

    5725M5400

  • Reported release

    703

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2020-02-05

  • Closed date

    2020-07-22

  • Last modified date

    2020-07-22

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    UC DEPLOY

  • Fixed component ID

    5725M5400

Applicable component levels

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS4GSP","label":"IBM UrbanCode Deploy"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.0","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
23 July 2020