IBM Support

PH18492: RUNNING ECLIPSE NEON 4.3, IDZ 14.2 P2 INSTALLATION FAILS WITH VISUAL DEBUG CONFLICTING DEPENDENCY WITH ADD NEW SOFTWARE

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • BM Developer for z/OS Enterprise Edition 14.2
    Running Eclipse Neon 4.3, IDz 14.2 P2 installation fails with
    Visual Debug conflicting dependency running
    the Add New Software IDZ 14.2 Update site
    (aqua3.1.27.update.site-20190905.zip)
    
    Steps to reproduce:
    1. Start eclipse Neon 4.3
    2. Perform Help>>Install new software
    3. Select aqua3.1.27.update.site-20190905.zip
    3. Select IBM Developer for z/OS plugins
    4. The installation fails with the folloiwing detils:
    Cannot complete the install because of a conflicting dependency.
      Software being installed: IBM® Developer for z/OS®
    14.2.0.201908292013
    (com.ibm.idz.categories.core.feature.feature.group
    14.2.0.201908292013)
      Software currently installed: Eclipse IDE for Java Developers
    4.6.3.20170314-1500 (epp.package.java 4.6.3.20170314-1500)
      Only one of the following can be installed at once:
        Debug UI 3.11.200.v20160518-1858 (org.eclipse.debug.ui
    3.11.200.v20160518-1858)
        Debug UI 3.6.3.v20110513_r363 (org.eclipse.debug.ui
    3.6.3.v20110513_r363)
        Debug UI 3.11.202.v20161114-0338 (org.eclipse.debug.ui
    3.11.202.v20161114-0338)
        Debug UI 3.11.201.v20160825-1412 (org.eclipse.debug.ui
    3.11.201.v20160825-1412)
        Debug UI 3.11.203.v20170707-1412 (org.eclipse.debug.ui
    3.11.203.v20170707-1412)
      Cannot satisfy dependency:
        From: Visual Debug 1.1.0.201908231431
    (com.ibm.debug.pdt.visual.debug 1.1.0.201908231431)
        To: bundle org.eclipse.debug.ui 3.11.203
      Cannot satisfy dependency:
        From: New Visual Debug 1.1.0.201908231431
    (com.ibm.debug.pdt.visual.debug.feature.feature.group
    1.1.0.201908231431)
        To: com.ibm.debug.pdt.visual.debug [1.1.0.201908231431]
      Cannot satisfy dependency:
        From: IBM® Developer for z/OS® 14.2.0.201908292013
    (com.ibm.idz.categories.core.feature.feature.group
    14.2.0.201908292013)
        To: com.ibm.debug.pdt.visual.debug.feature.feature.group
    [1.1.0.201908231431]
      Cannot satisfy dependency:
        From: Eclipse IDE for Java Developers 4.6.3.20170314-1500
    (epp.package.java 4.6.3.20170314-1500)
        To: org.eclipse.platform.feature.group
    [4.6.3.v20170301-0400]
      Cannot satisfy dependency:
        From: Eclipse Platform 4.6.3.v20170301-0400
    (org.eclipse.platform.feature.group 4.6.3.v20170301-0400)
        To: org.eclipse.debug.ui [3.11.202.v20161114-0338]
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * Users who have downloaded eclipse Neon from the eclipse.org  *
    * website and using the IDz P2 install package.                *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * P2 installation of IDz version 14.2 with Eclipse Neon 3      *
    * failed due to conflicting dependency from a Visual Debug     *
    * plugin.                                                      *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    

Problem conclusion

  • Visual Debug has adjusted it plugin dependency versions in order
    to be able to support eclipse Neon when downloaded from
    eclipse.org instead of AQUA.
    
    This issue is fixed in the following products:
    IBM Developer for z Systems
    IBM Developer for z Systems Enterprise Edition
    IBM Developer for z/OS
    IBM Developer for z/OS Enterprise Edition
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH18492

  • Reported component name

    DEV FOR Z/OS

  • Reported component ID

    5724T0700

  • Reported release

    E10

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-10-24

  • Closed date

    2019-12-09

  • Last modified date

    2019-12-09

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    DEV FOR Z/OS

  • Fixed component ID

    5724T0700

Applicable component levels

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSJK49","label":"IBM Developer for z Systems"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"E10","Edition":"","Line of Business":{"code":"LOB17","label":"Mainframe TPS"}}]

Document Information

Modified date:
27 October 2020