IBM Support

PH13379: Z/OSMF UI63197 AND UI63210 NEED TO HAVE BOTH UI62356 AND UI62361 FROM LIBERTY APPLIED. 19/06/14 PTF PECHANGE

A fix is available

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • z/OSMF UI63197 and UI63210 need to have both UI62356 and
    UI62361 from Liberty applied.
    
    UI62356 from APAR PH10543 does a delete of older versions of
    Liberty and UI62361 from APAR PH10544 does the actual install of
    the the Liberty version.
    
    UI63197 and UI63210 create a new symlink for z/OSMF to Liberty
    based on the
    19.0.0.3 level.  This correctly specifies UI62356 as a co-req,
    but this does not have a req of UI62361 .
    
    If only UI62356 is installed, version 19.0.0.3 won't
    be installed, but the z/OSMF Symlink is still created.
    
    
    
    ANALYSIS:
    z/OSMF Angel and Server task will fail with:
    
    BPXM047I BPXBATCH FAILED BECAUSE SPAWN (BPX1SPN)
    
    /usr/lpp/zosmf/liberty/lib/native/zos/s390x/bbgzangl FAILED WITH
    RETURN CODE 00000081 REASON CODE 0594003D.
    
    The /usr/lpp/zosmf/liberty directory is a symlink to a liberty
    directory that doesn't exist.
    
    KNOWN IMPACT:
    z/OSMF will not start up.
    
    VERIFICATION STEPS:
    Check the /usr/lpp/liberty_zos/ to verify if the directory named
    19.0.0.3 exists or not.
    
    PE INFORMATION:
    USERS AFFECTED:
    z/OSMF builds a symlink based on 19.0.0.3 being installed but it
    is not available and the startup fails.
    
    USER IMPACT:
    PH10949 and PH10955 fixed the problem it reported but introduced
    a new problem.
    

Local fix

  • BYPASS/CIRCUMVENTION:
    Install both UI62356 (PH10543 )  and UI62361 (PH10544 )
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All users of z/OSMF V2R3                                     *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * In order to upgrade WAS Liberty to                           *
    * version 19.0.0.3, Both WAS Liberty                           *
    * PTF UI62356 and UI62361 should be                            *
    * installed, so z/OSMF has to put both                         *
    * PTFs as prerequisite in order to                             *
    * point z/OSMF to WAS Liberty 19.0.0.3,                        *
    * but z/OSMF PTF UI63210 and UI63197                           *
    * just put PTF UI62356 as prerequisite.                        *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    

Problem conclusion

  • In order to upgrade WAS Liberty to
    version 19.0.0.3, Both WAS Liberty
    PTF UI62356 and UI62361 should be
    installed, so z/OSMF has to put both
    PTFs as prerequisite in order to
    point z/OSMF to WAS Liberty 19.0.0.3,
    but z/OSMF PTF UI63210 and UI63197
    just put PTF UI62356 as prerequisite.
    This APAR puts both UI62356 and UI62361
    as prerequisite.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH13379

  • Reported component name

    Z/OSMF LIBERTY

  • Reported component ID

    5655S28WL

  • Reported release

    230

  • Status

    CLOSED PER

  • PE

    YesPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-06-14

  • Closed date

    2019-07-11

  • Last modified date

    2019-08-01

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

    UI64148 UI64149

Modules/Macros

  • IZUWLSYM
    

Fix information

  • Fixed component name

    Z/OSMF LIBERTY

  • Fixed component ID

    5655S28WL

Applicable component levels

  • R230 PSY UI64148

       UP19/07/25 P F907 {

Fix is available

  • Select the PTF appropriate for your component level. You will be required to sign in. Distribution on physical media is not available in all countries.

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SG19O","label":"APARs - MVS environment"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"230","Edition":""},{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SG19M","label":"APARs - z\/OS environment"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"230","Edition":""}]

Document Information

Modified date:
01 August 2019