IBM Support

PH12563: SUPPORT JIT DEPLOY OF EJB 1.X AND 2.X MODULES

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as new function.

Error description

  • EJB 1.x and 2.x modules that only contain session beans must
    be deployed with the EJB deploy tool.  JIT deployment should be
    expanded to provide support for these modules.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server deploying applications with EJB 1.x  *
    *                  or 2.x modules                              *
    ****************************************************************
    * PROBLEM DESCRIPTION: Extend Just-In-Time deployment to EJB   *
    *                      1.x and 2.x modules that don't          *
    *                      contain entity beans                    *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    Applications containing EJB 1.x or 2.x modules require use of
    the depecrated EJBDeploy tool. The Just-In-Time deployment
    feature of WebSphere Application Server should be extended to
    handle older EJB modules that don't contain entity beans.
    

Problem conclusion

  • In prior releases of WebSphere Application Server,
    Just-In-Time deployment only supported EJB 3.x modules. All
    applications with EJB 1.x and 2.x modules had to be processed
    by the EJBDeploy tool, which is deprecated.
    
    Now, any application with modules that do not contain entity
    beans can simply be installed and used without first using the
    EJBDeploy tool.  The createEJBStubs tool has also been updated
    to support EJB 1.x and 2.x modules containing remote
    EJB interfaces.
    
    The fix for this APAR is currently targeted for inclusion in
    fix packs 9.0.5.0 and 8.5.5.16 for WebSphere Application
    Server. Please refer to the Recommended Updates page for
    delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH12563

  • Reported component name

    WEBSPHERE APP S

  • Reported component ID

    5724J0800

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-05-28

  • Closed date

    2019-06-27

  • Last modified date

    2019-06-27

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBSPHERE APP S

  • Fixed component ID

    5724J0800

Applicable component levels

  • R850 PSY

       UP

  • R900 PSY

       UP

[{"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"850","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
17 October 2021