IBM Support

PH10733: CQTOOL IS NOT WORKING (SEVERAL MESSAGES WHEN TRYING TO LOGIN, RUN QUERY, EDIT RECORD...).

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • When trying to run the cqtool commands, the following messages
    are appearing.
    
    C:\Users\Administrator>cqtool login -u admin -p "" -d SAMPL -s
    SQL_Test
    
    >>> No getter registered for CqExUserDb.PUBLIC_TEMPLATES
    >>> No getter registered for CqExUserDb.PUBLIC_LIST_VIEWS
    >>> No getter registered for
    CqExUserDb.IS_PRIVILEGED_QUERY_ENABLED
    >>> No getter registered for CqExRecordType.FORM_LIST
    
    cqtool> run_query "Personal Queries/Needs Verification"
    
    >>> No getter registered for CqQuery.IS_PRIVILEGED
    >>> No getter registered for
    CqFieldDefinition.BACK_REFERENCE_FIELDNAME
    
    cqtool> edit_record
    
    Do you want to select records by record id? (yes/no):y
    Please enter a record id:SAMPL00000001
    Do you want to enter another id? (yes/no):n
    Do you want to select records by db id? (yes/no):n
    >>> No getter registered for CqExRecord.HIDDEN_FIELDS
    >>> No getter registered for CqExRecord.HIDDEN_FORMS
    >>> No getter registered for CqExRecord.HIDDEN_TABS
    >>> No getter registered for CqExRecord.VIEW_FORM_NAME
    >>> No getter registered for CqExRecord.VIEW_TAB_NAME
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * ClearQuest CLI                                               *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * When running CQTool commands, users see error messages like  *
    * "No getter registered for CqExUserDb".                       *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    

Problem conclusion

  • A fix is available in ClearQuest 9.0.1.12, 9.0.2.4 and 9.1.0.1.
    These error messages have been removed from CQTool commands.
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH10733

  • Reported component name

    CLEARQUEST WIN

  • Reported component ID

    5724G3600

  • Reported release

    901

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-04-08

  • Closed date

    2021-07-01

  • Last modified date

    2021-07-01

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    CLEARQUEST WIN

  • Fixed component ID

    5724G3600

Applicable component levels

[{"Type":"MASTER","Line of Business":{"code":"LOB36","label":"IBM Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
02 July 2021