IBM Support

PH09485: USERS WITHOUT COMPONENT TEMPLATE READ PERMISSION CANNOT RUN COMPONENT PROCESSES FROM THE SAME TEMPLATE

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • There exists a component template with 3 component processes,
    p1, p2, and p3.
    Contents of p1 and p2 do not matter. p3 simply calls component
    processes p1 and p2.
    A component, c1, uses the component template. So c1 has p1, p2,
    and p3 via the template.
    If a user has component permissions, but not component template
    permissions, they can run p1 and p2, but they cannot run p3 due
    to not having component template read permission.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * All end users on all supported browsers.                     *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * There exists a component template with 3 component           *
    * processes,                                                   *
    * p1, p2, and p3.                                              *
    * Contents of p1 and p2 do not matter. p3 simply calls         *
    * component                                                    *
    * processes p1 and p2.                                         *
    * A component, c1, uses the component template. So c1 has p1,  *
    * p2,                                                          *
    * and p3 via the template.                                     *
    * If a user has component permissions, but not component       *
    * template                                                     *
    * permissions, they can run p1 and p2, but they cannot run p3  *
    * due                                                          *
    * to not having component template read permission.            *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Fixed in version 7.0.3.3                                     *
    ****************************************************************
    

Problem conclusion

  • Fix is provided in IBM UrbanCode Deploy 7.0.3.3
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH09485

  • Reported component name

    UC DEPLOY

  • Reported component ID

    5725M5400

  • Reported release

    627

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-03-07

  • Closed date

    2019-09-03

  • Last modified date

    2019-09-03

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    UC DEPLOY

  • Fixed component ID

    5725M5400

Applicable component levels

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS4GSP","label":"IBM UrbanCode Deploy"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"627","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
03 September 2019