IBM Support

PH07936: MIGRATING TO WAS V9.0 BUT APPLICATION DID NOT GET DEPLOYED.

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • The WASPostUpgrade log show:
    MIGR0340W: Application App1.ear did not deploy.
    -
    The application deploy trace file (App1.ear.trace) shows:
    ADMA0010E: Validation error in task Selecting virtual hosts for
    Web modules. A virtual host is not specified for web module
    native.war with URI native.war,WEB-INF/web.xml."" follows:
     com.ibm.ws.scripting.ScriptingException: WASX7109E:
    Insufficient data for install task "MapWebModToVH"
     -
    This problem is being seen because the web module has a web.xml
    file which is basically empty it is missing the *.xmi files.
    

Local fix

  • As a workaround edit the jython script and add the
    usedefaultbindings parameter to the "install" line as follows:
     AdminApp.install(earFile,'[-blaname
    "WebSphere:blaname=App1,blaedition=BASE" -nodeployejb -appname
    "App1" -usedefaultbindings -createMBeansForResources
    -noreloadEnabled -custom enhancedEarDisableValidation=true
    -server searver1 -node Node01]')
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server Migration WASPostUpgrade Tool        *
    ****************************************************************
    * PROBLEM DESCRIPTION: If a module in the applicaiton is not   *
    *                      mapped to a virtual host,               *
    *                      WASPostUpgrade will fail to install     *
    *                      the application.                        *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    A module in the application was not mapped to a virtual host,
    therefore the app install script did not have a -MapModuleToVH
    option provided which caused the app to not be deployed.
    

Problem conclusion

  • WASPostUpgrade will now add the -usedefaultbindings option to
    all the app install scripts. This option is used for any
    modules which do not have a virtual host mapping.
    The fix for this APAR is currently targeted for inclusion in
    fix pack 9.0.5.0 and 8.5.5.16.  Please refer to the Recommended
    Updates page for delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH07936

  • Reported component name

    WEBS APP SERV N

  • Reported component ID

    5724H8800

  • Reported release

    900

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2019-01-30

  • Closed date

    2019-05-31

  • Last modified date

    2019-05-31

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBS APP SERV N

  • Fixed component ID

    5724H8800

Applicable component levels

  • R850 PSY

       UP

  • R900 PSY

       UP

[{"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"900","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
17 October 2021