IBM Support

PH05700: WAS-USAGE-METERING.PROPERTIES DOES NOT WORK IN CLUSTER NAME DIRECTORY

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • was-usage-metering.properties not working in cluster name
    directory
    
    Documentation indicates usage metering should work if the
    config properties files is placed at the following location:
    
    Cluster directory:
    <profile_root>/config/cells/<cellName>/clusters/<clusterName>
    
    Other locations are functioning properly, but not the
    clusterName directory.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:  All users of IBM WebSphere Application      *
    *                  Server usage metering                       *
    ****************************************************************
    * PROBLEM DESCRIPTION: Placing was-usage-metering.properties   *
    *                      in the cluster configuration            *
    *                      directory does not enable usage         *
    *                      metering.                               *
    ****************************************************************
    * RECOMMENDATION:                                              *
    ****************************************************************
    The WebSphere Application Server runtime is not looking for
    was-usage-metering.properties in the correct location for the
    cluster configuration directory:
    Cluster directory:
    <profile_root>/config/cells/<cellName>/clusters/<clusterName>
    Usage metering will not be enabled if the configuration file
    is placed in this location. No messages will be present.
    

Problem conclusion

  • The server runtime has been updated to properly read the
    was-usage-metering.properties file in the documented location:
    
    Cluster directory:
    <profile_root>/config/cells/<cellName>/clusters/<clusterName>
    
    The fix for this APAR is currently targeted for inclusion in
    fix packs 8.5.5.15 and 9.0.0.11.  Please refer to the
    Recommended Updates page for delivery information:
    http://www.ibm.com/support/docview.wss?rs=180&uid=swg27004980
    

Temporary fix

Comments

APAR Information

  • APAR number

    PH05700

  • Reported component name

    WEBSPHERE APP S

  • Reported component ID

    5724J0800

  • Reported release

    850

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2018-11-27

  • Closed date

    2019-01-04

  • Last modified date

    2019-01-04

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBSPHERE APP S

  • Fixed component ID

    5724J0800

Applicable component levels

  • R850 PSY

       UP

  • R900 PSY

       UP

[{"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"850","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
17 October 2021