IBM Support

OA61272: CKF1010 08 PROGRAM AND ARGUMENT STRINGS: CONFIGURATION FILE CANNOT BE OPENED FOR SCANNING

A fix is available

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • CKF1010 08 Program and argument strings: configuration file
    cannot be opened for scanning
    
    A RACF violation is also seen when zSecure Collect attempts to
    gather information from certain z/OS Unix files for compliance
    evaluation purposes.
    
    In addition, message CKF1010 can not be suppressed and trying to
    suppress it results in message:
    CKF0166 12 Message number to be suppressed must be in range
    0..999
    

Local fix

  • Run CKFCOLL with a userid which has UID0
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED: Users of zSecure Collect versions 2.3.1 and  *
    *                 2.4.0 exploiting the SUPPRESS command to     *
    *                 suppress messages with numbers greater than  *
    *                 999. Users of zSecure Collect 2.4.0          *
    *                 processing OMVS address space data.          *
    ****************************************************************
    * PROBLEM DESCRIPTION: zSecure Collect version 2.3.1 issues a  *
    *                      MSG166I and zSecure Collect version     *
    *                      2.4.0 issues a MSG0166 in cases where   *
    *                      SUPPRESS command specifies message      *
    *                      numbers greater than 999. zSecure       *
    *                      Collect version 2.4.0 might issue a     *
    *                      MSGCKF1010 while processing OMVS        *
    *                      address space data.                     *
    ****************************************************************
    * RECOMMENDATION: Apply the PTF provided and review the        *
    *                 documentation updates.                       *
    ****************************************************************
    When SUPPRESS command supplied to zSecure Collect specifies
    message number greater than 999, the program issues a MSG166I
    (zSecure Collect version 2.3.0)/MSG0166 (zSecure Collect version
    2.4.0) which states "Message number to be suppressed must be in
    range 0..999".
    When zSecure Collect version 2.4.0 processes OMVS address space
    data, it might issue a MSGCKF1010 which begins with the text
    "Program and argument strings: configuration file cannot be
    opened ..." due to insufficient access level.
    

Problem conclusion

  • zSecure Collect versions 2.3.1 and 2.4.0 have been modified so
    that messages with numbers greater than 999 can be suppressed.
    zSecure Collect version 2.4.0 has been modified so that no
    MSGCKF1010 is issued due to insufficient access level while
    processing OMVS address space data. Please note the
    documentation changes as provided by the APAR tracking comment
    data.
    

Temporary fix

Comments

APAR Information

  • APAR number

    OA61272

  • Reported component name

    ZSEC BASE,ADMIN

  • Reported component ID

    5655T0100

  • Reported release

    231

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2021-04-20

  • Closed date

    2021-07-27

  • Last modified date

    2021-08-02

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

    UJ06110 UJ06111

Modules/Macros

  • CKFAS    CKFINPUT
    

Fix information

  • Fixed component name

    ZSEC BASE,ADMIN

  • Fixed component ID

    5655T0100

Applicable component levels

  • R231 PSY UJ06111

       UP21/07/28 P F107

  • R240 PSY UJ06110

       UP21/07/28 P F107

Fix is available

  • Select the PTF appropriate for your component level. You will be required to sign in. Distribution on physical media is not available in all countries.

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSPQTM","label":"IBM Security zSecure Admin"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"231"}]

Document Information

Modified date:
03 August 2021