IBM Support

JR57617: Random question mark characters (?) are included in outgoing emails

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • If you are on WebSphere Commerce Version 8.0.4.x you might
    notice that emails sent to customers include question mark
    characters (?) throughout the email.
    

Local fix

  • Update the LANGUAGE database table:
    update LANGUAGE set MIMECHARSET = "UTF-8" where LANGUAGE_ID =
    -1;
    

Problem summary

  • USERS AFFECTED:
    WebSphere Commerce Version 8 Mod Pack 4.
    
    PROBLEM ABSTRACT:
    Random question mark characters (?) are included in outgoing
    emails
    
    BUSINESS IMPACT:
    Email shows question mark characters throughout the email.
    
    RECOMMENDATION:
    

Problem conclusion

  • Updated English MIMECHARSET to UTF-8 in wcs.bootstrap_base.xml.
    

Temporary fix

Comments

APAR Information

  • APAR number

    JR57617

  • Reported component name

    WC BUS EDITION

  • Reported component ID

    5724I3800

  • Reported release

    800

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2017-03-20

  • Closed date

    2017-04-28

  • Last modified date

    2017-04-28

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WC BUS EDITION

  • Fixed component ID

    5724I3800

Applicable component levels

  • R800 PSY

       UP

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSYSYL","label":"WebSphere Commerce Enterprise"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.0","Line of Business":{"code":"LOB31","label":"WCE Watson Marketing and Commerce"}}]

Document Information

Modified date:
11 December 2021