IBM Support

JR33429: SFTP REQUIRES SUPPORT FOR OPENSSH 3.9 IN RED HAT LINUX 4

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • SFTP only support OpenSSH 4.3, but this version of OpenSSH is
    not supported by Red Hat 4. A fix to add support to OpenSSH 3.9
    is required for the SFTP on Red Hat Linux 4.
    

Local fix

Problem summary

  • ****************************************************************
    USERS AFFECTED:
    FTP EE Stage in SFTP mode for Information Server 8.1 for Linux
    AS 4
    ****************************************************************
    PROBLEM DESCRIPTION:
    Support for OpenSSH 3.9 on Redhat Linux AS 4
    ****************************************************************
    RECOMMENDATION:
    Install the patch. this issue is fixed in Information Server 81
    Fix Pack 1
    ****************************************************************
    

Problem conclusion

  • Implemented the changes required to support.
    
    Added an environment variable "APT_PFTP_SSH_CLIENT_VERSION"
     This environment variable can be set at the Project Level or
    theJob Level
    
     Set the above environment variable to the "SSH Client"
    version  which is in the path and needs to be used for the Job
     For example
           APT_PFTP_SSH_CLIENT_VERSION=3.9
          In the above case, we have set the OpenSSH Client version
    to    3.9
         The valid versions that are supported are OpenSSH 3.9 and
        OpenSSH 4.3
       If the above environment variable is set to any other value
      other that '3.9' or '4.3', it will default to the value 4.3
      If the environment variable is not set, then the job will use
      the default client version 4.3.
    

Temporary fix

Comments

APAR Information

  • APAR number

    JR33429

  • Reported component name

    WIS DATASTAGE

  • Reported component ID

    5724Q36DS

  • Reported release

    810

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2009-06-22

  • Closed date

    2009-06-26

  • Last modified date

    2009-12-22

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WIS DATASTAGE

  • Fixed component ID

    5724Q36DS

Applicable component levels

  • R810 PSN

       UP

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 December 2009