IBM Support

JR29864: STATIC BINDING OF SYBASE CLIENT LIBRARY REQUIRES XA-CAPABLE CLIENT

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • The static linking of data source client libraries is an
    error-prone process.  It also may force a customer to purchase a
    version of the client library that they don't actually need,
    simply because some symbols need resolution.  This occurs with
    Sybase in v9.5: The user must bind with the XA-capable client
    library from the Sybase SDK, rather than the free non-XA-capable
    library.
    

Local fix

Problem summary

  • Users affected: Users of the Sybase wrapper in InfoSphere
    Federation Server
    
    Problem description and summary:
    See error description.
    

Problem conclusion

  • Problem was first fixed in Version 9.5, FixPak 3 (s081118).
    This fix should be applied on the federation server.
    

Temporary fix

Comments

APAR Information

  • APAR number

    JR29864

  • Reported component name

    SYBASE WRAPPER

  • Reported component ID

    5724N9711

  • Reported release

    950

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2008-07-11

  • Closed date

    2008-12-30

  • Last modified date

    2008-12-30

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    SYBASE WRAPPER

  • Fixed component ID

    5724N9711

Applicable component levels

  • R950 PSN

       UP

[{"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSCAVPQ","label":"Data Sources and Wrappers - Sybase"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.5","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
30 December 2008