IBM Support

IY78390: Incorrectly built GCC 2.95.2 libraries shipped with WMQ V6.0 for Linux x86 platform

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • The GCC 2.95.2 libraries shipped with WMQ V6.0 are not linked
    correctly against the libstdc++-libc6.2-2.so.3 GCC 2.95.2
    library.
    
    These libraries are located in /opt/mqm/lib/2.95 for WMQ V6.0.
    The GCC 2.95.2 libraries shipped with WMQ V5.3 for Linux Intel
    were located in /opt/mqm/lib/2.95.2
    

Local fix

Problem summary

  • ****************************************************************
    USERS AFFECTED:
    Customers using GCC 2.95.2 on x86 platform to build WMQ C++
    applications, or attempting to use WMQ V5.3 C++ applications
    built using GCC 2.95.2 with WMQ V6.0.
    
    Platforms affected:
    Linux (Power),Linux (s390x),Linux (x86),Linux (x86-64),
    Linux (zSeries)
    
    ****************************************************************
    PROBLEM SUMMARY:
    A build problem caused these libraries to be built against an
    incorrect libstdc++.
    

Problem conclusion

  • The build configuration was altered to correctly build the
    libraries.
    
    Also, future maintenance deliveries for WMQ V6.0 will ensure
    that the following softlinks exist, to account for applications
    built using GCC 2.95.X compilers with WMQ V5.3:
    
    WMQ V6.0 for Linux x86 platform
                   /opt/mqm/lib/2.95.2 -> /opt/mqm/lib/2.95
    WMQ V6.0 for Linux zSeries platform
                   /opt/mqm/lib/2.95.3 -> /opt/mqm/lib/2.95
    
    ---------------------------------------------------------------
    The fix is targeted for delivery in the following PTFs:
    
                       v6.0
    Platform           Fix Pack 6.0.1.1
    --------           --------------------
    Linux (x86)        U805235
    Linux (x86-64)     U805770
    Linux (zSeries)    U805236
    Linux (Power)      U805237
    Linux (s390x)      U805769
    
    The latest available maintenance can be obtained from
    'WebSphere MQ Recommended Fixes'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006037
    
    If the maintenance level is not yet available, information on
    its planned availability can be found in 'WebSphere MQ
    Planned Maintenance Release Dates'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006309
    ---------------------------------------------------------------
    

Temporary fix

Comments

APAR Information

  • APAR number

    IY78390

  • Reported component name

    WEBS MQ FOR LIN

  • Reported component ID

    5724H7204

  • Reported release

    600

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2005-11-01

  • Closed date

    2005-11-29

  • Last modified date

    2007-08-02

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WEBS MQ FOR LIN

  • Fixed component ID

    5724H7204

Applicable component levels

  • R600 PSY

       UP

[{"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSCPQ5M","label":"APAR"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"6.0","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
02 August 2007