IBM Support

IT48071: INTEGRATION SERVER WITH A SPECIFIED JRE FAILS TO START WITH A BIP9396E AFTER UPGRADING TO 13.0.3.X FROM 13.0.1.X OR 13.0.2.X

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • If an Integration Server:
    1 - Required java 8 when it was migrated from an earlier version
    of WMB/IIB/ACE to ACE v13.0.1.X or ACE v13.0.2.X, and hence had
    its jre specified by 'ibmint extract node' or 'ibmint extract
    server'.
    2 - Or, had `ibmint specify jre` ran against it with ACE
    v13.0.1.X or ACE V13.0.2.X.
    Then when started with ACE 13.0.3.0 or 13.0.3.1, it will report
    a Fatal Exception BIP9396E.
    For example:
    "
    Fatal Exception aborting Server start: BIP9396E: The components
    specification could not be loaded from file
    ''/workpath/components/MYNODE/servers/MYSERVER/server.java.yaml'
    '
    BIP2786W: An unexpected property
    ''ResourceManagers/GlobalCache'' with value ''false'' was
    encountered when loading a YAML configuration.
    "
    

Local fix

  • Install this APAR fix.
    
    OR, Re-run ibmint specify jre with your
    desired jre level against the effected servers using 13.0.3.0,
    or 13.0.3.1.
    
    OR, uninstall the original version of ACE 13 that
    the JRE was specified with.
    

Problem summary

  • ****************************************************************
    
    USERS AFFECTED:
    Users of 13.0.1 or 13.0.2 that had a server specified to use
    java 17, who attempt to start those servers with 13.0.3
    
    
    Platforms affected:
    LinuxX64, LinuxPPCLE64, LinuxZ64, AIX, WinX64
    
    ****************************************************************
    
    PROBLEM DESCRIPTION:
    The servers that were specified to use java 17 will fail to
    start in 13.0.3 with errors like the following:
    
    "
    Fatal
    Exception aborting Server start: BIP9396E: The components
    specification could not be loaded from file
    ''/workpath/components/MYNODE/servers/MYSERVER/server.java.yaml'
    
    '
    BIP2786W: An unexpected property
    ''ResourceManagers/GlobalCache'' with value ''false'' was
    encountered when loading a YAML configuration.
    "
    

Problem conclusion

Temporary fix

Comments

APAR Information

  • APAR number

    IT48071

  • Reported component name

    APP CONNECT ENT

  • Reported component ID

    5724J0570

  • Reported release

    D0X

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2025-05-20

  • Closed date

    2025-06-16

  • Last modified date

    2025-06-16

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    APP CONNECT ENT

  • Fixed component ID

    5724J0570

Applicable component levels

[{"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSDR5J","label":"IBM App Connect Enterprise"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"13.0.0","Line of Business":{"code":"LOB77","label":"Automation Platform"}}]

Document Information

Modified date:
30 June 2026