IBM Support

IT36031: RHEL 8 INSTALLGSKIT DOES NOT INSTALL CORRECTLY IF EXISTING PREVIOUS VERSION

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as user error.

Error description

  • On RHEL8 with an existing installation with GSKit 8.0.50.89,
    installgskit doesn't install correctly, if customer ignores this
    installation error
    you'll see at startup following message:
    
    initialization of libisi.so.2 failed
    expected GSKit version: 8.0.55.12, but found 8.0.50.89
    
    And
    
    the symlink for $INFORMIXDIR/lib/libisi.so.2 is not created.
    
    ln -s $INFORMIXDIR/lib/libisi_gsk.so.2.0
    $INFORMIXDIR/lib/libisi.so.2  (this is needed)
    
    While trying to installgskit from the $INFORMIXDIR/gskit
    distributed  with products you'll see:
    
    From : $INFORMIXDIR/tmp/gskit.log
    
    warning: gskcrypt64-8.0.55.12.linux.x86_64.rpm: Header V3
    RSA/SHA256 Signature, key ID fbbfca9c: NOKEY
    warning: package gskcrypt64-8.0-50.89.x86_64 was already added,
    replacing with gskcrypt64-8.0-55.12.x86_64
    warning: package gskcrypt64-8.0-55.12.x86_64 was already added,
    replacing with gskcrypt64-8.0-55.17.x86_64
    Verifying packages...
    Preparing packages...
         package gskcrypt64-8.0-55.17.x86_64 does not verify: no
    digest
    Either GSKit package is already installed or an error occurred
    during RPM package installation.
    
    warning: gskssl64-8.0.55.12.linux.x86_64.rpm: Header V3
    RSA/SHA256 Signature, key ID fbbfca9c: NOKEY
    warning: package gskssl64-8.0-50.89.x86_64 was already added,
    replacing with gskssl64-8.0-55.12.x86_64
    warning: package gskssl64-8.0-55.12.x86_64 was already added,
    replacing with gskssl64-8.0-55.17.x86_64
    Verifying packages...
    Preparing packages...
         package gskssl64-8.0-55.17.x86_64 does not verify: no
    digest
    Either GSKit package is already installed or an error occurred
    during RPM package installation.
    
    So, in order to overcome this situation it needs to be run as:
    
    cd /opt/IBM/informix14/gskit
    tar xvf gskssl64-8.0.55.17.linux.x86_64.tar
    tar xvf gskcrypt64-8.0.55.17.linux.x86_64.tar
    rpm -ivh --nodigest --noverify --nosignature
    gskcrypt64-8.0.55.17.linux.x86_64.rpm
    rpm -Uvh --nodigest --noverify --nosignature
    gskcrypt64-8.0.55.17.linux.x86_64.rpm
    rpm -Uvh --nofiledigest --nodigest --noverify --nosignature
    gskcrypt64-8.0.55.17.linux.x86_64.rpm
    rpm -Uvh --nofiledigest --nodigest --noverify --nosignature
    gskssl64-8.0.55.17.linux.x86_64.rpm
    
    A side note is that while the GSKit is showing the errors,
    edition will always show DE no matter if xx_edition.jar is
    installed.
    
    After the GSKit issue is resolved it'll show the correct edition
    

Local fix

Problem summary

Problem conclusion

Temporary fix

Comments

  •  It appears that there is no inherent problem with this version
    of the OS.
    

APAR Information

  • APAR number

    IT36031

  • Reported component name

    INFORMIX SERVER

  • Reported component ID

    5725A3900

  • Reported release

    E10

  • Status

    CLOSED USE

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2021-02-24

  • Closed date

    2023-02-02

  • Last modified date

    2023-02-02

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

Applicable component levels

[{"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Product":{"code":"SSGU8G","label":"Informix Servers"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"E10"}]

Document Information

Modified date:
02 February 2023