IBM Support

IT35512: Setting OCSPAuthentication=REQUIRED generates AMQ7076 warning incorrectly

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • When MQ parses and validates the qm.ini file or mqclient.ini it
    throws AMQ7076W error when OCSPAuthentication=REQUIRED is
    set:
    
    AMQ7076W: Invalid value for attribute in ini file.
    
    EXPLANATION:
    
    Line ## of the configuration file
    
    '<Directory>/mqclient.ini' contained value 'REQUIRED' that is
    not valid for the attribute 'OCSPAuthentication'.
    
    OCSPAuthenticaiton=REQUIRED is a valid value and the default so
    this is not a valid warning.
    

Local fix

  • Although error is reported indicating invalid attribute, it
    proceeds using the default value of REQUIRED. If
    OCSPAuthentication=REQUIRED is set, the error will be written
    but OCSPAuthentication=REQUIRED will be the value used still.
    

Problem summary

  • ****************************************************************
    USERS AFFECTED:
    This issue affects users who have set
    OCSPAuthentication=REQUIRED in the queue manager or client
    configuration file.
    
    
    Platforms affected:
    MultiPlatform
    
    ****************************************************************
    PROBLEM DESCRIPTION:
    An error in the configuration file validation logic meant that
    the function incorrectly detected OCSPAuthentication=REQUIRED as
    an invalid value.  This resulted in the AMQ7076 warning message,
    and the attribute value being set to the default (REQUIRED), and
    so no functional impact was observed.
    

Problem conclusion

  • The configuration file validation logic is corrected to permit
    OCSPAuthentication=REQUIRED in the queue manager and client
    configuration files. This value remains the default, and so
    including this attribute/value pair in the configuration file is
    not mandatory.
    
    ---------------------------------------------------------------
    The fix is targeted for delivery in the following PTFs:
    
    Version    Maintenance Level
    v9.2 LTS   9.2.0.2
    v9.x CD    9.2.3
    
    The latest available maintenance can be obtained from
    'WebSphere MQ Recommended Fixes'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006037
    
    If the maintenance level is not yet available information on
    its planned availability can be found in 'WebSphere MQ
    Planned Maintenance Release Dates'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006309
    ---------------------------------------------------------------
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT35512

  • Reported component name

    MQ BASE V9.2

  • Reported component ID

    5724H7281

  • Reported release

    920

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2021-01-13

  • Closed date

    2021-03-23

  • Last modified date

    2021-03-23

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    MQ BASE V9.2

  • Fixed component ID

    5724H7281

Applicable component levels

[{"Line of Business":{"code":"LOB36","label":"IBM Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSYHRD","label":"IBM MQ"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"920"}]

Document Information

Modified date:
25 March 2021