IBM Support

IT32655: ERROR MESSAGE 'CAN NOT CONVERT TO ENCRYPTED SERVER' IS VAGUE

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • While upgrading from 11.70.FC8 to 12.10.FC13 with the
    DISK_ENCRYPTION parameter enabled, the instance can 'Assert
    Fail' with the
    error message 'Can not convert to encrypted server'. This error
    message can be made clearer and more informative to indicate
    that DISK_ENCRYPTION should not be set, while upgrading.
    
    04:11:56  Encryption-at-rest is enabled using cipher 'aes128'
    04:11:56  Dataskip is now OFF for all dbspaces
    04:11:56  Conv/rev: Started check phase of conversion for
    component RSAM
    04:11:56  *** numVersions=10 targetVersion=29 ***
    04:11:56  *** entity_ver=26  targetVersion=29  indexVersion=
    0***
    04:11:56  *** FromVersion=5  ToVersion=13 entity_ver=26
    targetVersion=29 indexVersion=0 ***
    04:11:56  *** FromVersion=13  ToVersion=14 entity_ver=26
    targetVersion=29 indexVersion=1 ***
    04:11:56  *** FromVersion=14  ToVersion=15 entity_ver=26
    targetVersion=29 indexVersion=2 ***
    04:11:56  *** FromVersion=15  ToVersion=16 entity_ver=26
    targetVersion=29 indexVersion=3 ***
    04:11:56  *** FromVersion=16  ToVersion=18 entity_ver=26
    targetVersion=29 indexVersion=4 ***
    04:11:56  *** FromVersion=18  ToVersion=25 entity_ver=26
    targetVersion=29 indexVersion=5 ***
    04:11:56  *** FromVersion=25  ToVersion=26 entity_ver=26
    targetVersion=29 indexVersion=6 ***
    04:11:56  *** FromVersion=26  ToVersion=27 entity_ver=26
    targetVersion=29 indexVersion=7 ***
    04:11:56  *** RSAM 1 12.10.xC1 ***
    04:11:56  *** FromVersion=27  ToVersion=28 entity_ver=27
    targetVersion=29 indexVersion=8 ***
    04:11:56  *** RSAM 1 12.10.xC4 ***
    04:11:56  *** FromVersion=28  ToVersion=29 entity_ver=28
    targetVersion=29 indexVersion=9 ***
    04:11:56  *** RSAM 1 12.10.xC8 ***
    04:11:56  Can not convert to encrypted server
    04:11:56  Conv/rev: Failed in check phase of conversion for
    component RSAM
    04:11:56  Conversion failed.
    04:11:56  *** Conversion failed ***
            CONVERSION_GUARD was on. To go back to the original
    version
            of IDS, run onrestorept.
    04:11:56  Assert Failed: *** Conversion failed ***
            CONVERSION_GUARD was on. To go back to the original
    version
            of IDS, run onrestorept.
    04:11:56  IBM Informix Dynamic Server Version 12.10.FC13
    04:11:56   Who: Session(5, informix@hostname, 0, 0x44f4bf18)
                    Thread(18, convert, 44f07008, 1)
                    File: framework.c Line: 970
    04:11:56   Results: Dynamic Server must abort
    04:11:56   Action: Restart conversion after fixing the problem.
    04:11:56  stack trace for pid 554 written to
    /opt/informix/IBM/12.10.FC13/tmp/af.3faedec
    04:11:56   See Also: /opt/informix/IBM/12.10.FC13/tmp/af.3faedec
    04:11:57  Thread ID 18 will NOT be suspended because
              it is deemed too critical to the server.
    04:11:57   See Also:
    /opt/informix/IBM/12.10.FC13/tmp/af.3faedec, shmem.3faedec.0
    04:11:57  Starting crash time check of:
    04:11:57  1. memory block headers
    04:11:57  2. stacks
    04:11:57  Crash time checking found no problems
    04:11:57  framework.c, line 970, thread 18, proc id 554, ***
    Conversion failed ***
            CONVERSION_GUARD was on. To go back to the original
    version
            of IDS, run onrestorept..
    04:11:58  The Master Daemon Died
    04:11:58  PANIC: Attempting to bring system down
    

Local fix

  • Upgrade to intended version, then encryption can be done by
    doing a backup, then restore with the -encrypt option, this will
    encrypt the dbspaces.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * Users of Informix Server prior to 12.10.xC15 and 14.10.xC5.  *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * See Error Description                                        *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * Upgrade to Informix Server 12.10.xC15 (when available) or    *
    * 14.10.xC5.                                                   *
    ****************************************************************
    New Error Message:
    DISK_ENCRYPTION is not supported during this upgrade. Please
    unset this config parameter and restart the conversion.
    

Problem conclusion

  • Fixed in Informix Server 12.10.xC15 and 14.10.xC5.
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT32655

  • Reported component name

    INFORMIX SERVER

  • Reported component ID

    5725A3900

  • Reported release

    C10

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2020-04-25

  • Closed date

    2020-12-29

  • Last modified date

    2020-12-29

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    INFORMIX SERVER

  • Fixed component ID

    5725A3900

Applicable component levels

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU029","label":"Software"},"Product":{"code":"SSGU8G","label":"Informix Servers"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"C10"}]

Document Information

Modified date:
30 December 2020