IBM Support

IT32233: MQ logger does not check the eye catcher or version before usingthe log record

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • A queue manager is started with a particular MQ version. Then
    the user reverts back to a
    lower MQ version and then starts the queue manager. If the log
    record version
    is different between the MQ version versions, the queue manager
    could fail to
    start with unexpected errors that are not helpful to understand
    the problem.
    Similar problem might also occur because of corrupted queue
    manager log records.
    

Local fix

Problem summary

  • ****************************************************************
    USERS AFFECTED:
    Users starting queue manager after reverting back MQ from higher
    MQ version to lower MQ version or with corrupted log records
    
    
    Platforms affected:
    MultiPlatform
    
    ****************************************************************
    PROBLEM DESCRIPTION:
    MQ did not check log record version before processing the log
    record causing
    unhelpful error messages during queue manager startup failure.
    

Problem conclusion

  • MQ code has been generated to check the log record version
    before processing the log record, in order to generate a more
    meaningful error message if the queue manager is being
    incorrectly started using an older product version.
    
    It remains invalid to start a queue manager at a lower version
    (CMDLEVEL) than the level at which it was previously run.
    
    ---------------------------------------------------------------
    The fix is targeted for delivery in the following PTFs:
    
    Version    Maintenance Level
    v9.0 LTS   9.0.0.11
    v9.1 LTS   9.1.0.6
    v9.x CD    9.1.5
    
    The latest available maintenance can be obtained from
    'WebSphere MQ Recommended Fixes'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006037
    
    If the maintenance level is not yet available information on
    its planned availability can be found in 'WebSphere MQ
    Planned Maintenance Release Dates'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006309
    ---------------------------------------------------------------
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT32233

  • Reported component name

    IBM MQ BASE MP

  • Reported component ID

    5724H7271

  • Reported release

    914

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2020-03-19

  • Closed date

    2020-06-26

  • Last modified date

    2020-06-26

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    IBM MQ BASE MP

  • Fixed component ID

    5724H7271

Applicable component levels

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSYHRD","label":"IBM MQ"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"914","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
27 June 2020