IBM Support

IT20457: ANS0340E OCCURS WHEN TRYING TO QUERY A VIRTUAL MACHINE BACK UP THAT WAS BACKED UP BY A HIGHER RELEASE OF THE CLIENT.

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • After backing up a VM on a client on the latest level of the
    Spectrum Protect client, a customer
    who will query the VM backup from a lower level of the Spectrum
    Protect client will receive the
    following misleading message:
    
    ANS0340E  A target storage pool does not have the correct data
    format for the given node type.
    
    Eg.:  The following query is issued from the same level of the
    Spectrum Protect client:
    
    Protect> q vm
    
    Query Virtual Machine for Full VM backup
    
     #      Backup Date       Mgmt Class  Size         Type     A/I
    Location  Virtual Machine
    ---  -------------------  ----------  -----------  ------   ---
    --------  ---------------
      1  03/31/2017 14:29:12  DDMGMT        100.00 GB  IFFULL    A
    SERVER    Swank2012
      2  04/14/2017 12:32:23  DDMGMT          1.00 GB  IFFULL    A
    SERVER    SmallVM2
    
    The following query is issued from the lower level of the
    Spectrum Protect client:
    
    Protect> q vm
    
    Query Virtual Machine for Full VM backup
    
     #      Backup Date       Mgmt Class  Size         Type     A/I
    Location  Virtual Machine
    ---  -------------------  ----------  -----------  ------   ---
    --------  ---------------
      1  03/31/2017 14:29:12  DDMGMT        100.00 GB  IFFULL    A
    SERVER    Swank2012
    ANS0340E A target storage pool does not have the correct data
    format for the given node type.
    
    The problem is that the message ANS0340E gives the impression
    that the back up has been
    corrupted when it has not.  The details of the backup can easily
    be retrieved using a higher level
    of the Spectrum Protect client.
    
    Products affected:
    IBM Spectrum Protect Backup-Archive Client version
    7.1 on Linux and Windows
    Note: The Backup-Archive Client is a prerequisite to using the
    Data Protection for VMware. In Data Protection for VMware
    environments, the Backup-Archive Client is also known as the
    data mover.
    
    This problem also affects IBM Spectrum Protect for Virtual
    Environments: Data Protection for VMware 8.1.0. If you are using
    Data Protection for VMware 8.1.0, refer to APAR IT20629.
    

Local fix

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * IBM Spectrum Protect for Virtual Environments Data           *
    * Protection for VMware versions 7.1 and 8.1.0 running on all  *
    * Microsoft Windows x64 and Linux x86 platforms.               *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * See Error Description.                                       *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * This issue is projected to be fixed in the Backup-Archive    *
    * Client version 7.1.8 on all Microsoft Windows x64 and Linux  *
    * x86 platforms                                                *
    * Note 1: The Backup-Archive Client is a prerequisite to using *
    * the Data Protection for VMware. In Data Protection for       *
    * VMware environments, the Backup-Archive Client is also known *
    * as the data mover.                                           *
    * Note 2: This is subject to change at the discretion of IBM.  *
    ****************************************************************
    

Problem conclusion

  • This problem has been resolved by issuing the following message
    when the problem occurs:
    
    ANS0200E The virtual machine 'vm_name' was backed up with a
    newer version of the client.
    
    The purpose of the new message is to make it clear to the end
    user that the reason for the failure is due to the lower level
    client not being able to display the information for the virtual
    machine that was backed up with a newer version of the client.
    Therefore, a newer version of the client will need to be used to
    display the virtual machine information.
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT20457

  • Reported component name

    TSM FOR VE DP V

  • Reported component ID

    5725TVEVM

  • Reported release

    71W

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2017-05-04

  • Closed date

    2017-05-17

  • Last modified date

    2017-05-17

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

    IT20629

Modules/Macros

  • dsmc
    

Fix information

  • Fixed component name

    TSM CLIENT

  • Fixed component ID

    5698ISMCL

Applicable component levels

  • R71W PSY

       UP

  • R71L PSY

       UP

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"71W","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
07 January 2022