IBM Support

IT07741: UPGRADE JAVA RUNTIME ENVIRONMENT SUPPLIED WITH WEBSPHERE MQ 7.1 7.5 and 8.0

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • The WebSphere MQ V7.1 and V7.5 installation contains a 1.6
    Java Runtime Environments (JREs), supplied within the JRE
    install component.
    The WebSphere MQ V8.0 installation contains a 1.7
    Java Runtime Environments (JREs), supplied within the JRE
    install component.
    New revisions of this JRE are released periodically to address
    program defects, and products which embed the JRE should
    be updated accordingly.
    

Local fix

Problem summary

  • ****************************************************************
    USERS AFFECTED:
    The JRE which is embedded into WebSphere MQ is used
    to run the following Java components of the product:
    
      WebSphere MQ Managed File Transfer
      GSKit graphical interface
      WebSphere MQ Explorer
      WebSphere MQ Extended Reach (MQXR) service
    
    
    Platforms affected:
    AIX, Linux on Power, Linux on S390, Linux on x86, Linux on
    x86-64, Windows, HP-UX PA-RISC, HP-UX Itanium, Solaris SPARC,
    Solaris x86-64
    
    ****************************************************************
    PROBLEM DESCRIPTION:
    This APAR updates the Java Runtime Environment (JRE) supplied
    with WebSphere MQ 7.1 & 7.5 to the level:
    
        Java 6.0 Service Refresh 16 Fix Pack 3 (SR16-FP3) with
    interm fix
    
    And the Java Runtime Environment (JRE) supplied
    with WebSphere MQ 8.0 to the level:
    
        Java 7.1 Service Refresh 2 Fix Pack 10 (SR2-FP10) with
    interm fix
    

Problem conclusion

  • This APAR updates the JRE updates for WebSphere MQ V7.1 and V7.5
    on the following platforms:
    
      AIX
      HP-UX Itanium
      HP-UX PA-RISC
      Linux (x86-32)
      Linux (x86-64)
      Linux (PPC64)
      zLinux
      Solaris (x86-64)
      Solaris (SPARC)
      Windows 32-bit
    
    This APAR updates the JRE updates for WebSphere MQ V8.0 on the
    following platforms:
    
      AIX
      HP-UX Itanium
      Linux (x86-32)
      Linux (x86-64)
      Linux (PPC64)
      Linux (PPC64LE)
      zLinux
      Solaris (x86-64)
      Solaris (SPARC)
      Windows 32-bit
      Windows 64-bit
    
    ---------------------------------------------------------------
    The fix is targeted for delivery in the following PTFs:
    
    Version    Maintenance Level
    v7.1       7.1.0.7
    v7.5       7.5.0.5
    v8.0       8.0.0.3
    
    The latest available maintenance can be obtained from
    'WebSphere MQ Recommended Fixes'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006037
    
    If the maintenance level is not yet available information on
    its planned availability can be found in 'WebSphere MQ
    Planned Maintenance Release Dates'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006309
    ---------------------------------------------------------------
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT07741

  • Reported component name

    WMQ WINDOWS V7

  • Reported component ID

    5724H7220

  • Reported release

    710

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2015-03-17

  • Closed date

    2015-04-30

  • Last modified date

    2015-04-30

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    WMQ WINDOWS V7

  • Fixed component ID

    5724H7220

Applicable component levels

  • R710 PSY

       UP

[{"Line of Business":{"code":"LOB36","label":"IBM Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSFKSJ","label":"WebSphere MQ"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1"}]

Document Information

Modified date:
09 March 2021