Troubleshooting
Problem
During an incremental backup of an HSM managed filesystem, the ANS4007E error is logged.
Cause
The common reason of error ANS4007E during the backup of an HSM managed filesystem is that the backup is done for a stub file and backing up the ACL of the stub file can trigger a recall. If the recall fails, the ANS4007E error will be displayed or logged in the dsmerror.log file
For an HSM managed filesystem which is configured to backup files before migration, under normal circumstances, the incremental backup will not select stub files or migrated files. However, the stub can be selected for backup for one of the following reasons :
- The directory where the stub resides is renamed
- The attribute changed
Environment
Tivoli Storage Manager Backup/Archive client and Space Manage Client.
Diagnosing The Problem
Below is an example of an incremental backup of an HSM managed file system which receives the error :
Normal File--> 182,779,904 /hsmtest/testfile ** Unsuccessful **
ANS1228E Sending of object '/hsmtest/testfile' failed
ANS4007E Error processing '/hsmtest/testfile': access to the object is denied
The "dsmls testfile" command would show the file as migrated. For example :
Actual Resident Resident File File
Size Size Blk (KB) State Name
182779904 4096 8 m testfile
Resolving The Problem
Dependending on the amount of error ANS1228E message, use of the below options.
- If there are only a few errors for a few files, do a manual recall of the files in error and resolve the issue if the recall fails. For example, recover the file from a backup copy.
- If this is a condition of a huge directory rename, use the "skipmigrated Yes" client option to allow backup of the resident files. After the backup is done with the resident files, you need to consider to remove the option and plan the backup of the migrated files as this can take a long time.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21392880