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Troubleshooting
Problem
A file backed up to a Tivoli Storage Manager server and needs to be restored. The restore operation fails with the ANS1314E error.
Cause
File to be restored is damaged or resides on volume currently unavailable to server
Resolving The Problem
Follow the below steps:
1) Get the exact name of the file in question.
2) Get the object_id of the file in question, this can be done with the following Tivoli Storage Manager server administrative command :
select object_id from {backups or archives} where node_name='NODENAME IN CAPS' and ll_name='filename in CAPS'
For example :
select object_id from backups where node_name='TEST' and ll_name='NSM_ERRIDENTIFY'
ANR2963W This SQL query may produce a very large result table, or may require a significant amount of time to compute. Do you wish to proceed? (Yes (Y)/No (N)) y
OBJECT_ID
--------------------
511049
Note: The filename will be in capital letters for Intel clients.
3) Run the following command to find out which volume the file resides on:
show bfo {object_id}
For example :
show bfo 511049
?Bitfile Object: 0.511049?**Sub-bitfile 0.511049 is stored in the following aggregate(s)
Super-bitfile: 0.510977, Offset: 0.1028530, Length 0.13784
NOTE: This output displays that the file represented by this object id (bitfile) is stored in a Super-bitfile: 0.510977 so we need to do the show bfo again for the Super-bitfile to get the name of the volume.
show bfo 510977
**Sub-bitfile 0.510977 is stored in the following aggregate(s)
Super-bitfile: 0.510977, Offset: 0.0, Length 0.739
**Disk Bitfile Entry
Bitfile Type: CACHED Storage Format: 22
Logical Size: 0.3789958 Physical Size: 0.3792896 Number of Segments: 1
Storage Pool ID: 4 Volume ID: 165 Volume Name:E:\TSMDATA\SERVER1\DISK1.DSM
**Archival Bitfile Entry
Bitfile Type: PRIMARY Storage Format: 22
Bitfile Size: 0.3789958 Number of Segments: 1
Storage Pool ID: 6 Volume ID: 167 Volume Name:E:\TSMDATA\SERVER1\00000003.BFS
The above shows that the bitfile is stored on the E:\TSMDATA\SERVER1\00000003.BFS storage pool volume with a cached copy still on the diskpool volume because caching is turned on. This entry will not be displayed if caching is disabled or the file has been removed from cache.
4) Now, verify if the volume is in an unavailable or destroyed state with the QUERY VOLUME command. For example :
query volume E:\TSMDATA\SERVER1\00000003.BFS F=D
5) If the volume is not in an unavailable or destroyed state, then it is possible for the file to be in a damaged state on the volume. You can issue the QUERY CONTENT command with the DAMAGED=YES parameter to verify if the file is damaged. For example :
query content E:\TSMDATA\SERVER1\00000003.BFS damaged=yes
6) If the file is reported as damaged, an AUDIT VOLUME with FIX=NO should be run to verify if the file can be read. If so, the file will be marked as undamaged. For example :
audit volume E:\TSMDATA\SERVER1\00000003.BFS fix=no
7) If the audit volume command cannot repair the file, then consider using the MOVE DATA command followed by the RESTORE VOLUME command to restore the file from copy pool volumes if copy pool volumes are available.
Finally, if the file cannot be recovered from copy pool, this file cannot be restored/retrieved as the object is damaged.
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Document Information
More support for:
Tivoli Storage Manager
Software version:
All Supported Versions
Document number:
86923
Modified date:
17 June 2018
UID
swg21249032