Troubleshooting
Problem
ANS4007E Error processing \\
Symptom
The following can be reported in the client error log (dsmerror.log, by default)
ANS1228E Sending of object '\\<filespace>\path\filename>' failed
ANS4007E Error processing '\\<filespace>\path\filename>': access to the object is denied
Cause
In environments where the user running the backup has sufficient authority (i.e. in the Administrators or Backup Operators groups), encryption applications can still block access to client files. The behavior has been seen with Credant Encryption software, but other encryption software may behave in a similar fashion.
Diagnosing The Problem
First, ensure that the permissions of the user running the backup allow access to the files being backed up, as documented in the client guide:
http://www.ibm.com/support/knowledgecenter/SSGSG7_7.1.0/com.ibm.itsm.client.doc/c_start_consider.html
Next, if applicable, attempt the following:
- 1) identify the application that owns the files reporting the ANS4007E messages
2) halt the application
3) attempt another backup
Resolving The Problem
If encryption software is being used , either disable encryption software or contact the encryption software manufacturer to determine if there is a work around.
The behavior seen with Credant software is that someone must be logged onto the system in order for Credant to be able to supply the encryption keys. If no users are logged into the system, the System account cannot receive the encryption keys, which cause the ANS1228E/ANS4007E messages to be reported.
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21993314