IBM Support

ANS1017E TCPIP error is reported when restoring from large backupset without TOC

Troubleshooting


Problem

When restoring specific files from a large backupset, the server needs to read all backupset tapes. The client session may close with ANS1017E before the needed file(s) could be restored.

Symptom

The following is the error as reported in Tivoli Storage Manager Command Line:

[root@hostxxx]:/ dsmc restore backupset /fs/path/filexx /fs/restorepath/ -backupsetname=TEST-BKSET.44444444
.....
Restore function invoked.
ANS1247I Waiting for files from the server...
After some time ...
>>>>>> Restore Processing Interrupted!! <<<<<<
ANS1017E Session rejected: TCP/IP connection failure
[root@hostxxx]

On Tivoli Storage Manager server side, no error or timeout messages are reported.

Cause

A system or firewall timeout closed the session before it could complete

Environment

Client restoring specific files from a large backupset without using TOC.

Diagnosing The Problem

Check if the client session is not closed due to any Tivoli Storage Manager server timeouts. In the server activity log, search for message like:

ANR0481W Session session number for node node name (client platform) terminated - client did not respond within commtimeout seconds seconds.

or

ANR0482W Session session number for node node name (client platform) terminated - idle for more than idletimeout minutes minutes.

If those messages do not appear before the time of the ANS1017E on client side, then the server is not responsible for the session closure, so this technote may apply.

Resolving The Problem

The solution is the same than the one documented in the technote shown in the URL section. In the other technote the problem is a hang of the client session while here a session lost error is reported instead of a hang situation

Tivoli Storage Manager uses the SO_KEEPALIVE network socket option. The SO_KEEPALIVE option allows Tivoli Storage Manager to enable periodic transmissions on a connected socket, when no other data is being exchanged.
The solution is to decrease the SO_KEEPALIVE interval to allow the session to be kept alive even if no transmission happen.
The default keepalive interval can be updated to a different value. For example, to set a keepalive interval of 10 minutes, the following command can be issued :

  • on AIX, "no -o tcp_keepidle=1200"
  • on Solaris, "ndd -set /dev/tcp tcp_keepalive_interval 600000"
  • on Linux Redhat "sysctl -w net.ipv4.tcp_keepalive_time=600"
  • on Windows, use Registry Editor (at your own risk) to modify/create value data for the "KeepAliveTime" DWORD value to 600000 in the following registry key: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
NOTE: The problem may also happen when there is no firewall in place between client and server.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21957993