Troubleshooting
Problem
Point In Time RESTORE DB operation may fail to find a backup candidate when the current Tivoli Storage Manager server language does not match the language the volume history file is written in.
Symptom
The DSMSERV RESTORE DB TODATE=TODAY fails with:
ANR4593E Restore database unable to find eligible candidate to use for processing.
ANR4602E No volumes found for TODATE 03/23/2015 23:59:59.
Cause
The LANGUAGE option of the Tivoli Storage Manager Server is not the same on source and target server.
Environment
Tivoli Storage Manager V7 servers on all platforms.
Diagnosing The Problem
Check the language of the volume history file. Problem will occur if the language the volume history file is written in is not installed and activated before starting the restore. For example, the following volume history file entry will need you to install Italian language (as all entries are in Italian) and activate it on the Tivoli Storage Manager server before the restore:
***********************************************************
Data/ora dell'operazione: 2015/03/02 12:22:41
Tipo di volume: BACKUPFULL
* Location for volume X:\DBBACKUP\123456.DBV is: ''
Nome volume: "X:\DBBACKUP\123456.DBV"
Serie di backup: 25
Operazione di backup: 0
Seq volume: 100001
Nome classe periferica: FILEDEV
**************************************************
Resolving The Problem
Install the needed Tivoli Storage Manager language package.
Adjust the LANGUAGE option in the "dsmserv.opt" file before starting the restore again.
See section below, there is a link to the documentation showing the values which can be used for LANGUAGE option.
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg21700142