Troubleshooting
Problem
Performing a Tivoli Storage Manager BACKUP DB fails with an ANR2983E and sqlerrmc value of 409.
Symptom
The following is an example of the sqlerrmc 409 taken from a Tivoli Storage Manager activity log:
- ANR2017I Administrator ADMIN issued command: BACKUP DB type=full devc=file
ANR8340I FILE volume /home/tsminst1/vols/64078609.DBV mounted.
ANR0511I Session 5 opened output volume/home/tsminst1/vols/64078609.DBV.
ANR1360I Output volume /home/tsminst1/vols/64078609.DBV opened (sequence number 1).
ANR0984I Process 5 for Database Backup started in the BACKGROUND at 03:43:29 PM.
ANR4559I Backup DB is in progress.
ANR2280I Full database backup started as process 5.
ANR4626I Database backup will use 1 streams for processing with the number originally requested 1.
ANR2968E Database backup terminated. DB2 sqlcode: -2033.DB2 sqlerrmc: 409.
ANR0985I Process 5 for Database Backup running in the BACKGROUND completed with completion state FAILURE at 03:43:36 PM.
ANR1893E Process 5 for Database Backup completed with a completion state of FAILURE.
Cause
The SERVERNAME specified in the $DSMI_CONFIG is not configured properly in the $DSMI_DIR/dsm.sys file.
Resolving The Problem
To resolve the sqlerrmc 409 error follow the steps outlined below.
- Log in as Tivoli Storage Manager instance user.
- Issue the following OS command to verify your DSMI_* variables are configured:
- The output of the env command should be similar to the following:
- If your DSMI_* variables are not defined, you will need to refer to the Preparing the database manager for backup section of the publications. If you variables are defined continue to the next step.
- Next you will want to cat the contents of the tsmdbmgr.opt file:
- The contents of tsmdbmgr.opt should be similar to the following:
- Now the $DSMI_DIR/dsm.sys file needs to be verified that the SERVERNAME specified in the tsmdbmgr.opt is defined in the dsm.sys file.
- Search for a stanza with the same name as defined in the tsmdbmgr.opt file.
- If it does not exist, the dsm.sys file will need to be updated with the following (update the directories specified to match your setup):
env | grep DSM
DSMI_DIR=/opt/tivoli/tsm/client/api/bin64
DSMI_LOG=/home/tsminst1/tsminst1
DSMI_CONFIG=/home/tsminst1/tsminst1/tsmdbmgr.opt
NOTE: in v7.1 the default path for DSMI_DIR changed to /opt/tivoli/tsm/server/bin/dbbkapi
cat $DSMI_CONFIG
* --------------------------------------------------------------- *
* This file was created by the TSM Instance Configuration Utility *
* --------------------------------------------------------------- *
SERVERNAME TSMDBMGR_TSMINST1
cat $DSMI_DIR/dsm.sys
SERVERNAME TSMDBMGR_TSMINST1
* --------------------------------------------------------------- *
* Stanza was added by the TSM Instance Configuration Utility *
* --------------------------------------------------------------- *
COMMMETHOD TCPIP
TCPPORT 1500
TCPSERVERADDRESS 127.0.0.1
PASSWORDACCESS generate
NODENAME $$_TSMDBMGR_$$
PASSWORDDIR /home/tsminst1/tsminst1
ERRORLOGNAME /home/tsminst1/tsminst1/tsmdbmgr.log
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]
Product Synonym
TSM ADSM
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Document Information
Modified date:
17 June 2018
UID
swg21632061