IBM Support

ANR2971E Database backup fails with DB2 sqlcode -2428 error

Troubleshooting


Problem

ADM1847W and ADM8010E failure messages in the db2diag.log during a Tivoli Storage Manager Database backup

Symptom

The db2diag.log will show the failure:
2013-10-20-10.06.25.366000-300 E21132061F430      LEVEL: Warning
 PID     : 2352                 TID  : 5780        PROC : db2syscs.exe
 INSTANCE: SERVER1              NODE : 000
 EDUID   : 5780                 EDUNAME: db2logmgr (TSMDB1)
 FUNCTION: DB2 UDB, data protection services, sqlpgRetrieveLogFile, probe:4165
 MESSAGE : ADM1847W  Failed to retrieve log file "S0000121.LOG" on chain "0" ...
2013-10-20-10.06.26.335000-300 E21133962F582      LEVEL: Severe
 PID     : 2352                 TID  : 6740        PROC : db2syscs.exe
 INSTANCE: SERVER1              NODE : 000         DB   : TSMDB1
 APPHDL  : 0-17348              APPID: *LOCAL.SERVER1.091020141532
 AUTHID  : SYSTEM
 EDUID   : 6740                 EDUNAME: db2bm.6700.4 (TSMDB1)
 FUNCTION: DB2 UDB, database utilities, sqlubProcessLogExtent, probe:1772
 MESSAGE : ADM8010E  Backup was unable to copy requested log file "S0000121.LOG" for inclusion in the backup image. The backup has been aborted.

Cause

The sqlcode -2428 translates to SQL2428N: "The BACKUP did not complete because one or more of the requested log files could not be retrieved."

This is caused by a missing log file in the active or archive log directories. The most common cause is running out of log space in one of the log directories while DB2 attempts to move or retrieve the original log.

Diagnosing The Problem

Look at the Tivoli Storage Manager Activity Log and check for any errors or failure messages during the time of the backup. For example, if there was a mount or I/O failure when attempting to retrieve the archived DB2 log file.

Search the db2diag.log file during this same time period to check for any error messages, for example, search for the message ADM1847W and an entry similar to the following:


    MESSAGE : ADM1847W Failed to retrieve log file "<LOG_NAME>" on chain "##" from "<LOG_PATH>".

Use the <LOG_NAME> to search thru the db2diag.log to determine whether the required log file was previously archived.


Search the system for the <LOG_NAME> to determine if it exists on the system. It should be located in either the archive, active, mirror, or archive failover log directories.

Resolving The Problem

If the log file was previously, successfully archived to the Tivoli Storage Manager Server, then correct any problems that are stopping the log file from being retrieved for inclusion in the database backup.

If the log file referenced by the <LOG_NAME> exists on the system, make a copy of this log and move it from its current location to the LOG_PATH which is specified in ADM1847W message. Then re-attempt the Tivoli Storage Manager DataBase backup.

If the log file cannot be found, it may be necessary to shutdown the Tivoli Storage Manager Server and perform a DB2 database backup that does not include the logs. Then restart the Tivoli Storage Manager Server and again attempt the Database Backup. This should no longer require the log file that was missing and be able to proceed. The reason for the missing log file should be investigated to prevent reoccurrence of this issue.

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Product Synonym

TSM

Document Information

More support for:
Tivoli Storage Manager

Software version:
All Supported Versions

Document number:
240237

Modified date:
17 June 2018

UID

swg21665809