IBM Support

ANR2968E occurs during failed Tivoli Storage Manager server database backup

Troubleshooting


Problem

Tivoli Storage Manager server database backup fails with error: . ANR2968E DB2 sqlcode: -2033.  DB2 sqlerrmc: 29

Cause

Most likely, the Tivoli Storage Manager server was not set up correctly before attempting the first database backup. The Sqlerrmc 29 is an API return code and means DSM_RC_ABORT_NO_STORE_SPACE_STOP. This error implies that the storage was not set up correctly.

Resolving The Problem

Carefully following the steps in the section titled "Preparing the database manager for backup" in the Tivoli Storage manager 6.x installation guides will allow the database to backed up (see URL link below).


Also ensure the SET DBRECOVERY command was issued to specify the device class to be used for the Tivoli Storage Manager Server database backups.

[{"Product":{"code":"SSSQWC","label":"Tivoli Storage Manager Extended Edition"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21395551