Troubleshooting
Problem
IBM Spectrum Protect server database backup fails with ANR2968E SQL2033N rc 109
Symptom
The following messages are displayed during a database backup attempt:
ANR0984I Process 2 for Database Backup started in the BACKGROUND at 10:03:48.
ANR4559I Backup DB is in progress.
ANR2280I Full database backup started as process 2.
ANR8340I FILE volume <volname> mounted.
ANR0513I Process 2 opened output volume <volname>.
ANR1360I Output volume <volname> opened (sequence number 1).
ANR4626I Database backup will use 1 streams for processing with the number originally requested 1.
ANR2968E Database backup terminated. DB2 sqlcode: -2033. DB2 sqlerrmc: 109.
ANR1361I Output volume <volname> closed.
ANR0515I Process 2 closed volume <volname>.
ANR0985I Process 2 for Database Backup running in the BACKGROUND completed with completion state FAILURE at 10:03:50.
ANR1893E Process 2 for Database Backup completed with a completion state of FAILURE.
Cause
0109 E DSM_RC_INVALID_PARM Invalid parameter was found.
There can be various causes for the 109 return code. In this case, the password for the $$_TSMDBMGR_$$ node had not been set.
Resolving The Problem
The $$_TSMDBMGR_$$ node is listed in the tsmdbmgr.opt file located in the server instance directory and is responsible for database backups. If the password has not been set, the $$_TSMDBMGR_$$ will not have the ability to open a session with the IBM Spectrum Protect server and begin the database backup.
Run the following command to resolve the error and set the password:
"c:\program files\tivoli\tsm\server\dsmsutil.exe" UPDATEPW /NODE:$$_TSMDBMGR_$$ /PASSWORD:TSMDBMGR /VALIDATE:NO /OPTFILE:"c:\program files\tivoli\TSM\server1\tsmdbmgr.opt"
Restart the IBM Spectrum Protect server and retry the database backup.
More information can be found here:
Product Synonym
TSM Tivoli Storage Manager ADSM
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Document Information
Modified date:
17 June 2018
UID
swg21698705