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ANR0928E Unable to open trace file when enabling tracing

Troubleshooting


Problem

ANR0928E error occurs in response to issuing the "trace begin " command for the Tivoli Storage Manager server.

Symptom

After issuing the 'trace begin <filespec>' command the following error is logged in the activity log.

ANR0928E Unable to open trace file c:\tracedir\trace.txt for appending.

Cause

The path, location or file specified for the trace does not exist or is not writeable.

Resolving The Problem

Two common causes of this error are:

1. The path to the trace is invalid. Ensure the path (including volume name and folder paths) exists prior to this command being issued. For example, on a Windows system, folder "C:\temp" must exist if issuing the command 'TRACE BEGIN C:\temp\trace.txt'
The trace is written to a file located on the Tivoli Storage Manager server host operating system.

2. The account used to start the Tivoli Storage Manager server process has insufficient privileges to write to the folder or file specified for the trace data. Ensure that the operating system account being used to start the server can create a file in the target location.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

More support for:
Tivoli Storage Manager

Software version:
All Supported Versions

Document number:
461657

Modified date:
17 June 2018

UID

swg21569293