Troubleshooting
Problem
'ANR0236E Fail to start the database manager due to an I/0 error...' may be displayed when starting the server.
Symptom
ANR0236E Fail to start the database manager due to an I/0 error. Check for filesystem full conditions, file permissions, and operating system errors.
Cause
The DB2 configuration is not correct
Resolving The Problem
Running the following commands may resolve the issue:
As the database instance owner:
- db2stop force
As root:
- # cd /opt/tivoli/tsm/db2/instance
# ./db2iupdt -u <tsmuser> <tsminstance>
As database instance owner:
- db2 connect to TSMDB1
Notes:
- <tsmuser> is the user name which was created to own this TSM instance
<tsminstance> is the instance name returned when the db2ilist command is run as the <tsmuser>
Start the Tivoli Storage Manager server.
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21677705