IBM Support

Analyst's Notebook fails to upload items to Information Store after upgrading to IBM i2 Analyze 4.2.0

Troubleshooting


Problem

After upgrading from i2 Analyze 4.1.6 and Analyst's Notebook 9.0.8, as part of Enterprise Insight Analysis (EIA) 2.1.7,  to i2 Analyze 4.2 and Analyst's Notebook 9.1.0, as part of EIA 2.2.0, logging in to the Information Store displays an error message, but the login is successful.  Subsequently, creating an item and attempting to upload it to the Information Store results in more errors.

Symptom

When  logging into the Information Store, this error message is displayed:
System.Net.WebException: Error en el servidor remoto: (503) Servidor no disponible. (Error in the remote server: (503) Server not available. ) en System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)

... but then the login is successful.

Then you create item and press the upload key in the Record inspector:

image-20180917144524-1

Then you get this error: (a web response error has occurred)

image-20180917144702-2

...and then you get this error when you press OK (a system error has occurred).

 

image-20180917144758-3

 

 

 

 

 

 

 

 

Cause

It appears that some upgrade considerations were not followed.

In the Record inspector, there are no security dimensions/values present.

image-20180917145715-4

 

Here is the security schema...

<SecurityDimensions Id="812fb036-dd9b-4190-bf9e-fd89c01f84d6" Version="9">
  <AccessSecurityDimensions>
   <!--- Configuración dimensión Informante no ordenada -->
   <Dimension  Id="SD-INF"
      DisplayName="Informante"
      Description="Fuente desde donde proviene el dato"
      Ordered="false">
    <!-- DimensionValue Id="P" DisplayName="Dato Publico" Description="Dato Publico"/-->
    <DimensionValue Id="E" DisplayName="Externa" Description="Fuente Externa"/>
    <DimensionValue Id="I" DisplayName="Interna" Description="Fuenta Interna"/>
    
   </Dimension>
   
   <!--- Configuración dimensión Privacidad ordenada -->
   <Dimension  Id="SD-PRIV"
      DisplayName="Privacidad"
      Description="Privacidad"
      Ordered="true">
    <DimensionValue Id="US" DisplayName="Ultra Secreto" Description="Dato Ultra Secreto"/>
    <DimensionValue Id="CONF" DisplayName="Confidencial" Description="Dato Confidencial"/>
    <DimensionValue Id="S" DisplayName="Secreto" Description="Dato Secreto"/>
    <DimensionValue Id="PUB" DisplayName="Publico" Description="Dato Publico"/>
   </Dimension>

 

But here is what was in the ApolloServerSettingsMandatory.properties

# The list of default security dimension value set on a record by default when you are using 

# the com.i2group.disco.user.PropertyBasedDefaultSecurityDimensionValuesProvider class. 

# This is only applicable to the Information Store with Opal Services. 

# Format: [Dimension value ID 1],[Dimension value ID 2],[Dimension value ID n] --> 

DefaultSecurityDimensionValues=CON,OSI,HI

These should match the values you have in your security schema. ... ie they should be I,E, (and one value from the SD-PRIV dimension ... US or CONF or S or PUB.  

DefaultSecurityDimensionValues=I,E,PUB

 

 

 

Resolving The Problem

To resolve this issue:

See "Other upgrade considerations" in this link...

https://www.ibm.com/support/knowledgecenter/SSXVXZ_2.2.0/com.ibm.i2.iap.upgrade.doc/other_upgrade_config.html

image-20180919161106-1

 

https://www.ibm.com/support/knowledgecenter/SSXVXZ_2.2.0/com.ibm.i2.eia.go.live.doc/t_set_default_security.html

In a deployment with the Opal services, when users create Information Store records in Analyst's Notebook Premium, i2 Analyze applies a default set of dimension values to the record. Similarly, when the Information Store ingests data, the created records receive dimension values during the process. 

About this task 

You might change the default security dimension values that are applied to records for different reasons: 

· If you change the dimensions or dimension values in your security schema. 

· If the security requirements of your deployment change. 

Regardless of your reason for changing the default security dimension values, or when the values are applied, each record must have at least one dimension value from each security dimension. 

Procedure 

1. When analysts create Information Store records in Analyst's Notebook Premium, the records receive default security dimension values. To change the set of security dimension values that records receive by default: 

a. In a text editor, open the configuration\fragments\common\WEB-INF\classes\ApolloServerSettingsMandatory.properties file from the deployment toolkit. 

b. Update the DefaultSecurityDimensionValues property with the identifiers of security dimension values that you want to be applied by default. 

For example, DefaultSecurityDimensionValues=CON,OSI,HI. 

2. In a standard deployment of i2 Analyze, a supplied implementation of the DefaultSecurityDimensionValuesProvider that applies dimension values from the DefaultSecurityDimensionValues property is used. You can create your own implementation by using i2 Analyze Developer Essentials. 

3. When data is ingested into the Information Store, the records that it contains receive their security dimension values during the ingestion process. 

To change the behavior of the ingestion process, update the contents of the <securityDimensionValues> element in the mapping file with the identifiers of security dimension values that you want to be applied by default. 

For more information about updating the default security dimension values that are applied during ingestion, see Information Store data ingestion. 

4. Redeploy and restart your deployment of i2 Analyze.

 

 

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXVTH","label":"i2 Analyze"},"Component":"","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"4.2.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
19 September 2018

UID

ibm10731819