IBM Support

All Writers Using *IBMSNMPDRV System Driver Program End With Message CPD337A on V7R5

Question & Answer


Question

Why do all of the print writer that use the *IBMSNMPDRV system driver program immediately end with message CPD337A:  An error occurred while printing on device, on V7R5?

Cause

Existing LAN SNMP printer device descriptions use SNMPv1.
If you received a preinstalled IBM i system or performed a scratch installation of OS 7.5, SNMP V3 only support is enabled (ALWSNMPV3(*V3ONLY)) by default in the SNMP attributes.

All printers configured to use *IBMSNMPDRV system driver program fail to start because the printer device description on the IBM i and the printer hardware are not configured for SNMPv3 support.

Answer

To allow the existing SNMP printer device descriptions to work with SNMPv1, change the ALWSNMPV3 parameter in the SNMP attributes from *V3ONLY to *V3AGENT or *YES:
CHGSNMPA ALWSNMPV3(*V3AGENT)
Or
CHGSNMPA ALWSNMPV3(*YES)
 

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000CHFAA2","label":"Print"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions"}]

Document Information

Modified date:
29 September 2022

UID

ibm16825219