IBM Support

ALBD service inadvertently removed following failed upgrade to ClearCase 7.1.0.1 on Windows if ClearCase GUIs are running during the upgrade

Troubleshooting


Problem

This technote explains how to resolve an issue that can occur when upgrading to IBM Rational ClearCase (CC) 7.1.0.1 on Windows where the Atria Location Broker service is inadvertently removed if the upgrade is performed while ClearCase graphical user interface (GUI) applications are running.

Symptom


In the process of upgrading to ClearCase 7.1.0.1 on Windows if there are any ClearCase GUI applications (for example: CCDoctor.exe, ClearExplorer.exe, or others) running when the upgrade is attempted, the ALBD service is removed.


Note: If you also have ClearQuest MultiSite installed, refer to the solution below for important information.


The following symptoms are what you would expect to see if you have CC Doctor running during the upgrade. The error message that users see may be different when other GUIs (CC Doctor) are running and it is possible that the after effect of this issue may result in a situation where the ALBD service may start successfully, however, the GUIs may not work, however, the solution explained below is the same.


You will receive the following initial upgrade failure message during the upgrade:

Update failed.

Installation Manager fetched 329 files (352.17 MB) during this update attempt.  
You can keep these files to avoid fetching them again.    Installation Manager will delete
these files during a successful update of this or any other package.

Do you want to keep the fetched files?




At this point when you click on the OK, the Installation Manager performs an automatic rollback of ClearCase to the previous version. However, during that rollback it inadvertently removes the Atria Location Broker (ALBD) Service. You would know if your machine has run into this scenario if your ClearCase control panel applet looks like this:



If you then re-try the upgrade (after closing down the ClearCase Doctor application), you would receive this error message as it is trying to stop the Atria Location Broker Service, and it will fail since the service no longer exists:

Error during "pre-install configure" phase:

com.ibm.common.install.win32.Win32Helper



Cause


As part of the ClearCase upgrade, the install needs to replace the existing ccdoctor.exe and ccdoctor.dll files (along with several others). The install is unable to remove the files since they are in use and, therefore, generates the error. At this point while the rollback is happening it will inadvertently remove the ALBD service.

This issue has been identified as a product defect under APAR PK84481.

Note: There are other processes (such as cqintsvr11.exe) that can cause unfavorable update issues as well.

Diagnosing The Problem


To verify that your machine has run into this scenario you can first check to see what the ClearCase control panel says is the status of the ALBD service (and if it matches the output shown above). As a second check you could bring up Control Panel->Administration->Services and see if you can find a service entry called Atria Location Broker.

Resolving The Problem

Defect APAR PK84481 has been resolved in ClearCase version 7.1.1.


To resolve this issue you need to uninstall ClearCase and re-install ClearCase 7.1. Before doing so ensure that all Rational GUI applications are closed, and then apply the upgrade.

If you have the ClearQuest MultiSite shipping server installed, you must also uninstall ClearQuest.

During the uninstall you should see the following error (if you are only uninstalling ClearCase you will only see the error message once):


If these were the only errors on uninstall, you can safely ignore them. You also do not have to manually clean up the files left behind as the subsequent install will overwrite them. Once you have re-installed ClearCase (and ClearQuest if needed) you can now upgrade to 7.1.0.1, however, make sure the ClearCase Doctor is not running when you do so.

To avoid upgrade issues caused by issues related to these running processes, before upgrading you should reboot the machine. Then make sure that CCDoctor is closed down and that all ClearCase, ClearQuest, RequisitePro, and other Rational product processes are stopped.

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Document Information

Modified date:
16 June 2018

UID

swg21382643