Question & Answer
Question
Unable to mount a NFS filesystem.
Error 1831-011 permission or access denied on the NFS client.
You may also get an 1831-019 giving up on message.
Or, nfsmnthelp: <NFS server hostname>: Error -1 occurred.
mount: giving up on:
mount: giving up on:
Cause
The above errors indicates that the NFS server is unable to resolve the ip address of the NFS client to a hostname.
Answer
For example, if the NFS client is configured with multiple ip addresses such as aliases or the client is multihomed the mount request may use an ip address that the NFS server is unable to resolve. Use the traceroute command to determine which ip address the client is using in its mount request. The traceroute command should be executed on the NFS client .
trying to get source for <NFS server>
source should be 10.10.10.1
<.....>
The above message indicates that the NFS client is using 10.10.10.1 as its source ip address to contact the NFS server.
In order for a successful mount, the NFS server must be able to resolve the clients' ip address to a hostname and hostname to the same ip address. If the NFS server is unable to resolve the client's ip address add the client's ip address and hostname to DNS or to the NFS server's /etc/hosts file.
After modifying the /etc/hosts file on the NFS server, test to see if the NFS server can resolve the IP address of the NFS client by running the host command on the NFS server:
# host 10.10.10.1
# host <hostname returned>
The above command should return the name of the NFS client you entered in the /etc/hosts file.
Also, check the /etc/exports on the nfs server for the correct hostname if you have an 'access=' or 'root='
list.
Try the NFS mount attempt again on the client.
# mount <nfs server hostname>:<exported filesystem> <mount point>
e.g.
# traceroute <NFS server hostname>
The output will be similar to the following:
trying to get source for <NFS server>
source should be 10.10.10.1
<.....>
The above message indicates that the NFS client is using 10.10.10.1 as its source ip address to contact the NFS server.
In order for a successful mount, the NFS server must be able to resolve the clients' ip address to a hostname and hostname to the same ip address. If the NFS server is unable to resolve the client's ip address add the client's ip address and hostname to DNS or to the NFS server's /etc/hosts file.
After modifying the /etc/hosts file on the NFS server, test to see if the NFS server can resolve the IP address of the NFS client by running the host command on the NFS server:
# host 10.10.10.1
# host <hostname returned>
The above command should return the name of the NFS client you entered in the /etc/hosts file.
Also, check the /etc/exports on the nfs server for the correct hostname if you have an 'access=' or 'root='
list.
Try the NFS mount attempt again on the client.
# mount <nfs server hostname>:<exported filesystem> <mount point>
[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG10","label":"AIX"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]
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Document Information
Modified date:
16 February 2024
UID
isg3T1010988