Question & Answer
Question
trustchk: /sbin/rc.boot: Verification of attributes failed: hashvalue signature
trustchk: Verification of attributes failed: hash
trustchk: Verification of attributes failed: signature
trustchk: Verification of stanza failed:
Cause
- nohup /usr/sbin/syncd 60 > /dev/null 2>&1 &
+ nohup /usr/sbin/syncd 10 > /dev/null 2>&1 &:
# bosboot -a
trustchk: /sbin/rc.boot: Verification of attributes failed: hashvalue signature
trustchk: Verification of attributes failed: hash
trustchk: Verification of attributes failed: signature
trustchk: Verification of stanza failed:
# trustchk -y /sbin/rc.boot
trustchk: Verification of attributes failed: mode
trustchk: Verification of attributes failed: hash
trustchk: Verification of attributes failed: signature
trustchk: Verification of stanza failed:
Answer
# openssl genrsa -out /etc/security/TSDprivkey.pem 2048
# openssl req -new -x509 -key /etc/security/TSDprivkey.pem -outform DER -out /etc/security/TSDcertificate.der -days 3650
# openssl pkcs8 -inform PEM -in /etc/security/TSDprivkey.pem -topk8 -nocrypt -outform DER -out /etc/security/TSDprivkey.der
# trustchk -s /etc/security/TSDprivkey.der -v /etc/security/TSDcertificate.der -a $trustedFile
IBM recommends that you report the issue to the product team that provides the scripts or commands, so they can review their packaging or documentation to avoid causing trustchk errors.
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If you require more assistance, use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract. 1. Document (or collect screen captures of) all symptoms, errors, and messages related to your issue. 2. Capture any logs or data relevant to the situation. 3. Contact IBM to open a case: -For electronic support, see the IBM Support Community: 4. Provide a clear, concise description of the issue. - For more information, see: Working with IBM AIX Support: Describing the problem. 5. If the system is accessible, collect a system snap, and upload all of the details and data for your case. - For more information, see: Working with IBM AIX Support: Collecting snap data |
Related Information
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IBM Ideas: trustchk error message issued during bosboot after changing powerHA …
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Document Information
Modified date:
14 November 2023
UID
ibm17074527